Aller au contenu principal

IMac Intel 27 ". EMC 2309 (fin 2009, Core 2 Duo 3.06 ou 3.33 GHz), EMC 2374 (fin 2009, Core i5 2.66 GHz ou Core i7 2.8 GHz)

Questions au sujet de 523 Voir tout

Blank (black) Screen. With New SSD.

Installed new SSD to my new 2013 iMac. When I power up, the screen is blank as in black. When I put back the original HDD it works fine. Is there something I'm missing?

Répondu ! Afficher la réponse J'ai le même problème

Cette question est-elle utile ?

Indice 0
Ajouter un commentaire

4 solutions

Solution retenue

@Mads - So I can put a V8 engine into my VW Beatle then ;-}

Sadly it's not so simple. The SATA standard over the years has been improved. The way the different versions of the standard interoperate is not as straight forward as one would like.

So lets see if we can clarify: A fixed SATA device needs to match the systems SATA ports connection or be slower.

  • A fixed SATA II (3.0 Gb/s) device will work in a SATA II (3.0 Gb/s) system
  • A fixed SATA II (3.0 Gb/s) device will work in a SATA III (6.0 Gb/s) system (SATA devices are upwardly compatible)
  • A fixed SATA II (3.0 Gb/s) device will NOT work reliably in a SATA I (1.5 Gb/s) system (SATA devices are NOT downwardly compatible). The same logic applies for SATA III devices. They will not work reliably in either a SATA I or SATA II system.

Now to confuse you! So far we've been talking about FIXED speed devices. Well, some hardware makers want to sell their stuff to a more people so they offered a jumper on the device to allow one to slow down the device to match the system (SATA II drives often have these to work in SATA I systems, a few SATA III drives had them allowing to set the drive to SATA I). Later on the many device makers added circuitry able to sense the systems I/O speed so it would automatically adjust to the system. This is true for a few HD's & SSD's. So one needs to check the spec sheet. If it states only one speed then its fixed. As a reference here's the Seagate SSHD drive's spec sheet: Desktop SSHD Look at the line SATA Transfer Rates Supported (Gb/s) note the listing shows 6.0/3.0/1.5 which are the SATA III, SATA II & SATA I I/O speeds. Make sure the spec sheet states this if not it's not auto sensing.

OK, so you got the drive in and maybe it even allowed you to install the OS onto it so why are you telling me its wrong when it works? This gets into I/O errors! A mismatched drive will often encounter heavy I/O errors as the interface can't sustain the data flow. If the data flow is slow (installing from a slow CD/DVD or USB drive) the flow is not heavy enough to create many errors. But once the OS is installed an app or the indexer process will fire up causing the system to over heat as the CPU & the drive are in a data fight between the constant reads & writes as most fail so they need to go into retry.

Cette réponse a-t-elle été utile ?

Indice 3

Commentaires:

Hi Dan, the issue here I my black screen. I can see me iMac via external monitor. And I found the 6gb/s hd in drive utility (I still boot my old hdd) I format the SSD and enable trim to prepare it for installation of a clean OSX. I tested the speed of the SSD to 250mb/s as mentioned in main question, so I assume that mean the SSD Is working as it should (I can read/write from it).

So why is my screen still black?

par

I think we all took a left turn here instead of a right. I suspect you mis-connected your display data & sync cables. Be careful here! If you reversed the connection you will damage the logic bd circuitry.

par

Ok, here is some focused images in data cable you see any issues? image 1 seems to show a dark spot right on the cable mount, is that a burned port? http://postimg.org/gallery/yibeczte/46d4...

par

As to the SATA issue. I still think you have an issue there. Review the system specs: iMac 27" 3.06 GHz Core 2 Duo (Late 2009) This system only has a SATA II (3.0 Gb/s) SATA port.

par

Ouch! Yep you blow the front end logic. At this point you'll need to get a new graphics board (if its removable) or try to fix this one if possible (less than a 50-50% chance).

par

Voir 16 commentaires en plus

Ajouter un commentaire

Of course you formatted and installed the OS on the new drive. Could you be using a SATA III (6Gb/s) drive on your machine thats built for SATA II (3Gb/s), Some of the new drives, although calming backward compatibility, are giving users problems that trace back to having to be manually jumpered to the lower speed.

You might need to do an EFI update while the old drive is installed.

If this answer is acceptable please remember to return and mark it.

.

Cette réponse a-t-elle été utile ?

Indice 2

Commentaires:

Tried to startup Imac with and without ssd connected. I dont think the ssd has influence on the display. 6gb/s should work fine on 3gb/s logic board it just doesn't get the full speed out of the 6gb/s hd. I speed tested the ssd to 250mb/s r/w normally this ssd can do 500mb/s r/w on a 6gb/s logicboard. But Evo 850 is simply the best value for money SSD in 2015 from my research.

par

Ajouter un commentaire

Eco 850 works fine with iMac 2013, format it and try again installing new OS X.

Cette réponse a-t-elle été utile ?

Indice 0

Commentaires:

@Jozo - Yes the EVO 850 is a nice SSD, but the issue is the SATA connection in this series. This is an older system with a different SATA version (Yours SATA III (6.0 Gb/s) this system SATA II (3.0 Gb/s). But thats not the problem presently. Right now the issue is the video which was damaged in the process of the swap out.

par

Ajouter un commentaire
Cette réponse correspondait à l'origine à une autre question .

Having successfully replaced the my iMac (Mid-2011 27ich 2.7ghz i5) hard drive with and SSD, after 30 days of use the screen has blacked out. The computer continues to function via external monitor. Disconnecting the display and reseating the cables fixes the problem temporarily. I’ve cleaned out the inside of the Mac, it is now free from dust. Having done this it worked for another 20 days or so and has blacked out again.

The tech specs indicate that the SSD is compatible with my iMac, however I do push the computer pretty hard using various design programmes.

I’ve tried everything. The fan speed is set at the right temp etc.

Maybe reinstalling the original Hard Drive and installing the SSD in the optical port will make a difference? This is my last port of call. Advice very much welcome!

Cette réponse a-t-elle été utile ?

Indice 0
Ajouter un commentaire

Ajouter une réponse

John sera éternellement reconnaissant.
Afficher les statistiques:

Dernières 24 heures : 1

7 derniers jours : 4

30 derniers jours : 19

Total : 2,867