Aller au contenu principal

Starting problem with ignition?

I have a 2012 Harley-Davidson Sportster Evolution. I have NO digital clock/screen, horn,indicators,rear back/brake lights, reg light

I have engine start

Turn key to ignition,it starts,turn key slightly back a couple of mills and everything comes back on.

So between ACC-IGNITION.I have connection.

I also have digital clock display stand down,when it is up.

Répondu ! Afficher la réponse J'ai le même problème

Cette question est-elle utile ?

Indice 2
Ajouter un commentaire

4 Réponses

Solution retenue

faulty ignition due to key vibration,

buy after market round key ignition with 3 wires,Disconnect battery, splice into wiring loom, use electrical connectors to connect new wires into loom wires,If not get a electrical Mechanic to do it for you,Thats what i did cost £25to buy £20 to fit.job done,

Cette réponse est-elle utile ?

Indice 0
Ajouter un commentaire
Réponse la plus utile

Sounds like your ignition switch has a bad connection or contacts inside. Do you leave your bike outside or is it in a damp area? Try spraying some contact cleaner in the switch. Let it dry and see if that helps.

Cette réponse est-elle utile ?

Indice 3
Ajouter un commentaire

Thanks george,but its none of the above you wrote,My Harley is garage,I finally found out it was a contact inside ignition that had broke away due to flat keys riggling about because of vibration of engine,all 2015 wide glides also have same problem and have been recalled,over 3000 bikes.

I had a new ignition fitted with round key,Problem no more.:)

Kind regards Sam

Cette réponse est-elle utile ?

Indice 1

Commentaires:

I got a 1999 less 10000 miles riding it noticed the milage wuz blank got to where I needed to turn turn signal didnt work got it home killed it tryed to start it bck up it acted like battery wuz weak just got chickn sound what's my problem

par

Ajouter un commentaire

Block Image


I had the same problem. Ended up being rust inside the ignition switch. I had to store it outside for a few weeks. Had a cover on it, but the moisture rusted some contacts inside the switch.

I took the ignition switch off, removed the C-clip retainer, GENTLY pried out the round plastic piece holding the contacts inside, cleaned everything really well and removed rust by soaking in penetrant and scraping, put it back together and worked perfectly.

Cette réponse est-elle utile ?

Indice 1

Commentaires:

I have 2011superglide battery is draind when it starts l ride 2 mi starts shuttin on and off then dies anyone know what causes that

par

The stater switch?

par

Ajouter un commentaire

Ajouter une réponse

SMUDGER sera éternellement reconnaissant.
Nombre de vues :

Dernières 24 heures : 5

7 derniers jours : 35

30 derniers jours : 110

Total : 7,830