Aller au contenu principal

marantz weak and sometimes distorted channel

my marantz 2232 amplifer sometimes has weak output. moving or gently pushing in on the volume knob will sometimes corrects this, after a few minutes the problem comes back. the problem seems to get worse with longer run times.

Une réponse ! View the answer J'ai le même problème

Cette question est-elle utile ?

Score 0
Ajouter un commentaire

Fix Kits pour batteries d'iPhone

Seulement $29.99

Buy Now

Fix Kits pour batteries d'iPhone

Seulement $29.99

Buy Now

2 réponses

Solution retenue

Hi,

It seems that the volume control potentiometer is faulty. Depending on the type you may be able to fix it but is it usually easier to replace it. This is what it may look like, there are a lot of variations. The second image shows the 'electrical' equivalent of a potentiometer. What happens is that over time either the wiper blade loses tension or the resistive material that it slides on either goes a higher resistance or depending on whether it is wire wound or carbon track it can exhibit other fault conditions.

A lot of the time the 'resistive value' of the potentiometer is printed on it and its' power rating is usually determined by its' physical size.

Block Image

Block Image

If you are interested I found this video about how to repair a Marantz volume control potentiometer. I do not know if this is similar to your model or not, but it may be of interest to you. it shows a 'digital' potentiometer, whereas what I have described above could be called an analogue one. Even though they work in digital circuits. It is just a different way of altering resistance values, digital being more precise. https://www.youtube.com/watch?v=y4XF9Poi...

Cette réponse est utile ?

Score 3

Commentaires:

Thanks for your quick response. i have opened up the amp, The potentiometer looks like your typical unit much like the one you pictured, except the marantz seems to have a small metal box attached to the back of the meter. i was uncertian if this was part of the potentiometer. i will check into getting a replacement. thanks again, i have had a hard time finding any info on this model and any info is greatly appreciated.

par

Hi Nick,

If there is no info printed on the potentiometer, given that it was still working (of a fashion) if you use an Ohmmeter to measure the resistance between A & B (as per the drawing above) that will give you the value in Ohms of the potentiometer (measure it out of circuit). Your problem with it, I suspect is the connection that the wiper arm (W) makes to the resistance part. I could be wrong of course and that the whole 'pot' has gone off value, but it may be worth a test. With the small metal box on the back, it may be that it houses a component which is tied to the pot and needs to be shielded for some reason. Maybe it is best to wait and get a replacement before you try to open it and see what it, if anything, contains. Talking of replacements I don't know if this is the one for your model but this may be of interest, if you wish to spend the money. I don't know if it contains the info you want. Your decision. http://www.servicemanuals.net/ServiceMan...

par

Ajouter un commentaire

It is most likely a bad transistor or bad capacitor in the amplifier section of the amplifier. It may also be a dirty volume control pot that needs cleaning but since it happens more the longer the unit is on I would lean toward a bad transistor or capacitor in the unit.

Cette réponse est utile ?

Score 0
Ajouter un commentaire

Ajoutez une réponse

nick sera éternellement reconnaissant.
Voir les statistiques:

Dernières 24 heures : 0

7 derniers jours : 11

30 derniers jours : 45

Total : 1,161