Skip to main content

Battery operated Thomas the Tank Engine ride-on train with track.

18 Questions View all

Can't get drive motor to work

Hello, we have had the above toy given to us from a friend, but although battery was charged overnight, I can only get toy to play the music and noises. Even when on the track? I am more than happy to get new battery, if this may be the fault, but could there be a motor problem? Toy does not appear damaged in any way, and was assured it worked fine when it was given to us. Can the battery get so worn out that it will hold voltage to make noises but not enough power to turn wheels ??

Answer this question I have this problem too

Is this a good question?

Score -1
Add a comment

3 solutions

Your last question is very valid and yes that is very probable. If it's been a year or two on that battery ,then it's probably time. To be sure , get a small volt meter and see how many volts the battery has after charge. You can get a little more life out of it if you drain the battery alllll the way down. It might last a time or two or so but good luck . Oh motors are generally fused so it is possible you could have just blown one. Just trace wire down to find , Good Luck.

Was this answer helpful?

Score 0
Add a comment

Having same problem. When I wire the battery directly to the derive motor, the train moves. I'm told it's the circuit board (meva0024). Does anyone know where to get an inexpensive one? They are listed on some sites for $19.95 but unavailable. I'm not giving Peg Perego $60.00- $70.00 for it.

Thanks for your help.

Was this answer helpful?

Score 0
Add a comment

Hello, I remove the battery from thomas the train to charge. I'm having the same problem thomas doesn't move but the music does play even after I removed the battery.

Was this answer helpful?

Score 0
Add a comment

Add your answer

neathmad will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 3,068