Aller au contenu principal

Not turning on after power jack replacement.

I originally found this at a Flea Market, and had to replace the power jack on it. When I installed the new power jack, I accidentally cold worked the upper lead until it came off - the lead from the old jack was still intact, so I was able to replace that as well. When I went to test it though, the screen was black with some white flickering, before it went completely black, with no power light turned on. I've checked the Fuse, and the Fuse is able to to pass a continuity test. I'm confused at this point, since the fuse is the only thing I can think of that could be preventing it from turning on, especially with the power light off. Any suggestions? Could the polarity be getting mixed up somehow? I did have to remove the RF module temporarily in order to get the power jack on.

Any help would be appreciated.

Block Image

Edited 8-28-2016: The Power light does turn on when the switch is on - I took it to the local professional tech, and he thinks I may have accidentally fried something when I removed the RF module to put on the power jack. (apparently you can bend the RF module to some extent without desoldering it in order to fit on the new backplate/power jack.) He tried using a different RF module, Power Jack, and Voltage Regulator (if I'm remembering correctly) with no response. When I test it, I put in the cartridge, turn it on, and nothing appears on screen.

Répondre à cette question J'ai le même problème

Cette question est-elle utile ?

Indice 0

Commentaires:

@supportninja post some images of what you repaired so we can see what you see. Sounds like you ran into a few issues....

Rep: 201

par

I'll see if I can open it up again tomorrow to take some pictures.

par

Picture added - I'm tempted to redo the joints, since I think my iron was too hot. I soldered the Power Jack, and resoldered the RF Module after I removed it to put on the new jack.

par

Ajouter un commentaire

2 solutions

Réponse la plus utile

Check the inside cover of the unit. Its been years since I worked on these units, but if I remember correctly, Nintendo put in a small aluminum tamper tab at one point as they wanted to do all repairs and some units had these where when you opened the unit up, it would break cutting the circuit. You might have one of these units. Your going to need a really fine tip soldering iron to close the circuit if this is the case as its extremely easy to hit the other components next to it.

Cette réponse a-t-elle été utile ?

Indice 1

Commentaires:

Where would I find it on the board?

par

Ajouter un commentaire

There are actually a few things that could cause a SNES to not turn on (ask me how I discovered this). The main reason is a bad fuse, but you said you checked it and it's good. The next thing to check is the voltage regulator (squarish black box thing with three pins right near the fuse [not sure how familiar you are with circuits]). Test the input and output.; If you have no voltage (or close to it) at the input, then test the components upstream. If you have about 9V going into the regulator and anything other than 5V coming out, then replace the voltage regulator with a new 7805. I actually had a similar issue with my console and ended up on a forum to get answers to it. The issue with my console was that the D1 on the board had blown. Here's a simple way to tell if your D1 is bad: Plug the console in but leave it off. Wait 30 seconds or so then turn it on. If the red light on the front lights up for just an instant then goes out, then your D1 is likely bad. If it is bad, then you should be able to do this repeatedly with the same result each time. Test it to make sure (it's a plain old diode if it needs replacing, or you can just jump it with a wire, which I personally don't recommend). Here's a link to the forum I used and the question I posted, because at the time I was replacing the broken power port as well when I ran into problems. Hopefully it helps you out: http://forum.digitpress.com/forum/showth...

Cette réponse a-t-elle été utile ?

Indice 1

Commentaires:

Edited 8-28-2016: The Power light does turn on when the switch is on - I took it to the local professional tech, and he thinks I may have accidentally fried something when I removed the RF module to put on the power jack. (apparently you can bend the RF module to some extent without desoldering it in order to fit on the new backplate/power jack.) He tried using a different RF module, Power Jack, and Voltage Regulator (if I'm remembering correctly) with no response. When I test it, I put in the cartridge, turn it on, and nothing appears on screen. Unless this SNES managed to fry it somehow, the cartridge I'm using to test should be fine. Its a copy of Super Mario All Stars, and I was able load it properly on a SNES Mini I sold a few weeks ago.

par

Ajouter un commentaire

Ajouter une réponse

Ben Eccles sera éternellement reconnaissant.
Afficher les statistiques:

Dernières 24 heures : 0

7 derniers jours : 4

30 derniers jours : 21

Total : 879