Aller au contenu principal

Released March 2006, identified by model D620 on the keyboard bezel.

Questions au sujet de 44 Voir tout

When Power Supply is Plugged into The Computer It Shuts Off...Why?

I have a Dell Latitude D620. I did a system restore on it going back to a previous date in the computer. It went through the restore and rebooted itself. It then said system restore not complete, please try again. Redid the system restore a second time. It completed the restore and booted down and will not reboot. Now when you plug the adapter into the computer, the green light on the adapter goes off. If you unplug it from the computer and leave it plugged into the wall the adapter green light comes on but then when you attach it back to the computer it goes out again. I cannot start the computer without the adapter as the battery is dead. I have researched possible problems but cannot find anything. Anyone might know what the problem would be? When you have a moment and thank you for your time!

Répondu ! View the answer J'ai le même problème

Cette question est-elle utile ?

Score 0
Ajouter un commentaire

3 solutions

Solution retenue

Here is a link to a previous question that may help you. Since this happened after a system restore it could also be corrupted operating system or a failing hard drive. Another possibility would be a failing power adapter.

Dell laptop won't start!!

Cette réponse a-t-elle été utile ?

Score 2
Ajouter un commentaire

The battery is not charging from your description.

1. power off, remove battery and put on charger and then try again. battery shorts are common on the D620.

2. try another power adapter as the power adapters have a pretty high failure rate on the D series Latitude laptops (I have over 120 of them at my office, they are not very reliable and have many issues)

3. check and clean battery and power contacts

4. check power connectors to mb and to batt

update if these do not work

Cette réponse a-t-elle été utile ?

Score 1

Commentaires:

a few questions:

1. did you change the ram configuration?

2. did you have video issues before the restore?

3. does it get to the POST?

4. does the power adapter when plugged in "wiggle" easily?

many issues cause these symptoms so I am just trying to nail it down. sorry about taking so long to respond.

par

Ajouter un commentaire

WELL…I have green light issue but I had dropped my pc a little on plush carpet a year ago bending the cord tip inside the inner power jack..However, with a little maneuvering, it has worked fine and charged easily for 1 year until yesterday when I plugged cord in..a few sparks flew and green light on cord turns off whenever inserted into pc. My husband says it needs a pigtail or “power jack”replaced. He claims he can do this but various pc tech people claim he could fry the pc….YouTube has many instructions to fix problem if the inner spot (jack) is broken or twisted? and you know someone that can do this..Who knows?? I’ll soon see if i can find out where to get the replacement part and if hubby blows the pc up… Good luck!!!

Cette réponse a-t-elle été utile ?

Score 0
Ajouter un commentaire

Ajouter une réponse

Lisa sera éternellement reconnaissant.
Afficher les statistiques:

Dernières 24 heures : 6

7 derniers jours : 44

30 derniers jours : 171

Total : 11,027