Aller au contenu principal

IMac Intel 27 ". EMC 2309 (fin 2009, Core 2 Duo 3.06 ou 3.33 GHz), EMC 2374 (fin 2009, Core i5 2.66 GHz ou Core i7 2.8 GHz)

Questions au sujet de 522 Voir tout

Microphone does'nt work after repair

Hi!

I did a repair this weekend which included the removal of the logicboard (I replaced the battery on the back).

Everything went well and the iMac works just fine now afterwards. But the built in microphone seams dead, the bars in the sound setting doesn't show any life what so ever when I test it in the sound settings.

So I'm thinking that perhaps I forgot a connector or something, I don't know. Seams odd though, thinking that all the work took place at the lower part of the iMac and the microphone is located at the top. The built in webcam works just fine I can add.

So my question to you experienced iFixers is:

Did I forget a connector or what do you think could have happened to the mic, regarding my repair the day before?

I'm going to take a look this the upcoming weekend, so any tip would be much appreciated.

Répondre à cette question J'ai le même problème

Cette question est-elle utile ?

Indice 4

Commentaires:

Hi, I have the same issue, did you figure it out? Thanks

par

Ajouter un commentaire

2 solutions

@dubcode

If I remember correctly the tiny holes in the microphone was impossible to align with the equally tiny holes in the chassi of the iMac. So I ended up with drilling a larger hole in the iMacs chassi and then I got it to work again.

My solution wasn't pretty, but I got it to work.

You can probably check if the holes in your mic is blocked to by simply letting the hole thing hang outside and see if its working then. Or you might have a cool idea of aligning the holes better then me.

Anyways, good luck!!

I covered the hole with stuff I found at home, see pic :-).

Block Image

Cette réponse a-t-elle été utile ?

Indice 0
Ajouter un commentaire

Thanks Peter,

Actually no the tiny holes are not blocked and the imac is open with the screen lying on my table

When i opened my mac to install a new Blade SSD i had to disconnect the microphone cable.

Then i thought it was broken because i reconnected after the surgery and no sound

I ordered a new one and no sound

Did a PRAM reset and still no microphone sound

My mistake is that i did not see the tiny latch when i disconnected that microphone in the first place (it is super tiny and fragile)

I have no clue what to do, it it an iMac 27 2019 and i really enjoyed using that imtegrated microphone for facetime or videoconference

Cette réponse a-t-elle été utile ?

Indice 0

Commentaires:

Ok, thats different from my old 2009 iMac then. I don’t remember any tiny latch on my machine. Where is the latch located, on the microphones connector?

if everything else fails and you can’t find help, you could buy an external usb mic. Maybe not your first solution but fairly cheap I think.

par

Ajouter un commentaire

Ajouter une réponse

Peter sera éternellement reconnaissant.
Nombre de vues :

Dernières 24 heures : 0

7 derniers jours : 0

30 derniers jours : 2

Total : 139