Aller au contenu principal

Model A1418 / Late 2013 / 2.7 & 2.9 GHz Core i5 or 3.1 GHz Core i7 Processor

Questions au sujet de 130 Voir tout

No power on, no trickle voltage on logic board, blown Mosfet

Hi all.

We have a suspected power surge on a late model iMac.

Logic board ID 820-3588 , power supply tested OK and swapped in known working power supply.

Symptoms;

1. No Trickle diag LED at all

2. No power on , chime etc

Blown Q7610 dual N channel mosfet which is a FDMS3602s FET

http://www.mouser.com/ds/2/149/FDMS3602S...

No other liquid or burn marks on board itself.

Mosfet appears to have shorted or had voltage applied beyond its limits.

Fet failed dramatically after a few power on attempts and was not blown initially on inspection.

Have replaced part with exact match , no power on yet fet is intact thus far.

Anyone else seen anything like this?

Une réponse ! View the answer J'ai le même problème

Cette question est-elle utile ?

Score 3
Ajouter un commentaire

Fix Kits pour batteries d'iPhone

Seulement $29.99

Buy Now

Fix Kits pour batteries d'iPhone

Seulement $29.99

Buy Now

1 réponse

Solution retenue

I had to extrapolate from your part number which machine you had. Please let me know if the icon is your machine.

The first thing to do on this one is to replace the power supply:

iMac Intel 21.5" EMC 2638 Power Supply Replacement

Cette réponse est utile ?

Score 2

Commentaires:

Hi Mayer , yes indeed that is the iMac in question. Swapping the power supply has already been done and did not solve the issue sorry to say. All voltages into the logic board were correct with the original power supply also but swapped a new one in just in case.

par

Let get this straight, you replaced the power supply but get NO diagnostic LEDs?

par

This got confusing because you used two questions on the same problem but provided different information in the two. Then when it was caught (the duplicate question) they were combined. My answer was to the question that was deleted. It did not contain the information this question did on the power supplies. So PLEASE just ask the question once and if you need to add updates to the original question.

par

Not sure what you mean. I have posted two different issues on two different iMacs at different times. This one relates to an iMac that does not power on , no LED at all despite replacing the power supply. The thread above is quite strait forward.

To make it clearer.

iMac tested - No power on.

Screen removed - No LED lights at all.

Power supply swapped with known working one - No LED

Power on test - Blew mosfet as described above

Removed logic board - Replaced mosfet

Retested - No LED same original condition however the replaced mosfet is staying intact for now.

par

My iMac 2638 has the same issue. I bought a known good power supply, installed it, and the situation remained the same (no power, no boot, no fans, no diagnostic-LEDs at all...). Any ideas on a next step for this?

par

Voir 5 commentaires en plus

Ajouter un commentaire

Ajoutez une réponse

markduff sera éternellement reconnaissant.
Voir les statistiques:

Dernières 24 heures : 0

7 derniers jours : 4

30 derniers jours : 18

Total : 421