Aller au contenu principal

Model A1418 / Late 2012 / 2.7 & 2.9 GHz Core i5 or 3.1 GHz Core i7 Processor

Questions au sujet de 161 Voir tout

LCD Backlight & one ram slot dead, cause: mainboard?

Hello,

I was recently entrusted with a late 2012 21,5" iMac (EMC 2544) to repair. The problem was there was no display anymore.

Here is what I found:

* All four diagnostic LED are on

* I can connect to an external display

* I bought another iMac LCD on eBay but same result : nothing is displayed

* After looking for answers on the Internet I found that the backlight could be the cause: indeed, if I light the LCD with a torch I can see the pixels, so only the backlight is not working. Then I sent back the LCD I just bought.

* I found also that a dimm slot (slot 0) doesn't detect the RAM, however this RAM is detected on another laptop. This is not a priority repair, but it might help to find the root cause of the broken backlight.

* I totally disassembled the iMac without seeing any evident damage on the mainboard, but I think I missed something. Unfortunately I didn't take any good enough pictures and I reassembled it fully.

So far I'm trying to understand the circuit posted here (Where is the inverter circuit in the late 2012 iMac?) by @oldturkey03. Maybe a component died and it may have cause both the dimm slot and the LCD backlight to stop working. I cannot tell if the ram slot stopped working before or at the same time as the backlight.

I'm use to do repairs on PCs and smartphones when it is about changing whole pieces (LCD, mainboards...). However changing this iMac mainboard is really expensive. I also have basics on soldering and electronics and can read simple schematics (recent graduate engineer in embedded systems, yey) so I feel like I'm able to give it a try and I have nothing to loose (except my time), but for sure I do need your help on this one.

First, I am not used to Macs, did I forget to check something evident on this machine? If not, where should I start to check if some related components are dead?

Any support would be greatly appreciated :)

Thank you and have a great day!

Edit 2018-07-06: Here is the logic board in pictures:

Block Image

Block Image

Edit 2018-07-13 : @oldturkey03 you asked me to check some voltages. So the fuse F9700 is ok and there is 12V. But there is 0V at the resistor R9704. The mosfet (FDMS6681Z, named Q9702 in the schema) seems fine:

  • Rgd = 112 kOhm
  • Rsg = 71 kOhm
  • Rsd = 36,3 kOhm (keeps increasing, capacitance effect?)

Here are the mosfet voltages:

  • Vg = 12V
  • Vs = 12V : is it normal?
  • Vd = 0V : should be 12V, right?

Here are the mosfet pins I measured, just to be sure:

Block Image

Block Image

I tried to look around for damaged stuff but I cannot find the schema components on the logic board: Q9701, R9720, R9721, C9771...

Also I found a component that seemed damaged to me, the one with a question mark and a red circle on the previous picture. Check this:

Block Image

I thought it was a damaged capacitor but I only had a multimeter to test it. I unsoldered it and it looked like a 45 kOhm resistor, package 1206. It was a bit hard for me to solder it back. Maybe I overheated because at the end I measured 35 kOhm, but the iMac is still booting, phew.

You seem to know this circuit pretty well, do you know where I should check now, and do you know the name of the component I just abused lol?

Edit 2018-07-16 : Okay so with your corrections I remade a schema and took again voltages and resistances:

Block Image

Can you confirm if I've written the right components?

The backlight was fine a few weeks ago, it stopped working suddenly and they gave me the computer without any human intervention.

I wonder if there is something wrong with R9720. Either it's a faulty contact between the circuit and my multimeter or the resistance is absent (?), dead or unsoldered. I cannot see because it's hidden on the other side of the board.

Edit 2018-07-17: R9720 is not assembled as specified in the schema ("NO STUFF" = do not stuff, do not assemble), so it's open circuit.

Edit 2018-07-18: I had to give back the iMac today... They'll go to an Apple store to get a repair estimate. I hope to know how it ends, for the sake of curiosity...

Répondez à cette question J'ai le même problème

Cette question est-elle utile ?

Score 2

Commentaires:

@merinorus okay so right now it appears like you "just" do not have a backlight? What have you checked on the board itself? Post some good images of the boards with your question so we can see what you see. Use this guide Ajout d'images à une question existante for that.

Rep: 1

par

Yes exactly. Whether I put the current screen or a new screen, the display is working but without backlight. As soon as I can I will disassemble the computer again and post some detailled pictures. Thanks!

par

I have edited my answer with some pictures of the logic board. I didn't check anything specifically. I checked for any evident visual damage but didn't find any. Do you see anything suspicious?

If not, I would like to know if there are particular areas to check , maybe with the help of the circuit plan you submitted in the other thread.

Thank you again for your time!

par

Hello @oldturkey03 ,

I hope you are doing well.

If this is straightforward enough for you, could you please give me some hints where I should check on the main board ? I hope the photos show enough details, otherwise I wouldn't mind doing new ones.

Thanks a lot!

par

Ajouter un commentaire

Batteries pour ordinateurs portables

Une réparation facile pour un gain en puissance max.

Acheter maintenant

Batteries pour ordinateurs portables

Une réparation facile pour un gain en puissance max.

Acheter maintenant

1 réponse

Réponse la plus utile

@merinorus I’d start of with some simple voltage testing. Check on R9704 and see if you have 12VDC there. Check on F9700 and ensure it has continuity and 12VDC on it.

Block Image

Update (07/13/2018)

@merinorus that is FB9708. If you have 12V on the points you are showing but not turning on then you may have issues with eitehr Q9702 or with the backlight enable circuitry.

Block Image

Update (07/13/2018)

it would be good to know if the backlight has worked before or if there was any work done on the board.

Block Image

Cette réponse est utile ?

Score 2

Commentaires:

@oldturkey03 Thanks for the tip! I feel like I moved forwawrd a bit.

So I checked voltage. I edited my first post with the results.

par

@oldturkey03 Okay, I just sent you an email, also I've updated the first post again.

I'll keep this thread up-to-date if anything new!

par

@oldturkey03 I have same issue, but no voltage on R9704. Do you have any suggestion?

4th LED diagnostic is off.

Thank you in advance!

par

hello tomm, check the U7600 IC .

No power on, No LED on logic board

par

Ajouter un commentaire

Ajoutez une réponse

Antoine Merino sera éternellement reconnaissant.
Voir les statistiques:

Dernières 24 heures : 0

7 derniers jours : 4

30 derniers jours : 13

Total : 183