Aller au contenu principal

Réparez vos affaires

Droit à la réparation

Pièces & Outils

L'iMac est la ligne d'ordinateurs tout-en-un de bureau d'Apple.

Questions au sujet de 7948 Voir tout

Alimentation iMac A1225 EMC 2267 (voltage, démarrage)

Bonjour,

J’aurais besoin de quelques lumières au sujet des alimentations d’iMac, notamment celle du Early 2009 24” (A1225 EMC 2267).

J’ai décidé de bricoler un ancien iMac en panne (Machine qui s’éteint toute seule) pour en faire un Media Center avec mon Rasberry Pi et son Hifiberry + un contrôleur LCD. Mais pour bien faire, j’ai besoin d’utiliser l’alimentation pour l’écran (+ ventilo et pourquoi pas alimenter aussi le raspi).

Mais pour ça, j’ai besoin de deux choses :

  • Les tensions (et intensité) des connecteurs de sortie qui ne sont évidemment pas standard (12 pins pour le 12v-3.3v et 12 pins pour le 24v qui file vers l’inverseur de l’écran, bien que pour ce dernier, je m’en moque un peu).
  • Savoir quel pins il faut relier pour activer l’alim (si j’avais cet élément, je pourrais d’ailleurs mesurer moi même les voltages).

Pour l’heure, j’ai repéré 3 infos :

  • Pin 1 = Ground
  • Pin 2 = 12v always on
  • Pin 4 = 3.3v always on
  • Pin 6 = Ground

Pour le reste, je sèche, si vous me donniez un coup de main, je vous en serais extrêmement reconnaissant.

Mise à jour (08/09/2019)

Bonjour,

J'ai un peu avancé dans mes tests, j'ai réussi à activer l'alimentation !

Il suffit de faire un pont entre la masse (PIN 1,6,7,12) et le 3.3V (PIN 4), ce qui active les pins 8, 9, 10

On se retrouve donc avec ces valeurs :

Sur la sortie 12V (2x6 pins)

  • Pin 1 = GND
  • Pin 2 = 12VDC -> Always On
  • Pin 3 = GND -> si SATA connecté
  • Pin 4 = 3.3VDC -> Always On -> PS_ON
  • Pin 5 = ?
  • Pin 6 = GND
  • Pin 7 = GND
  • Pin 8 = 12VDC -> If On
  • Pin 9 = 12VDC -> If On
  • Pin 10 = 12VDC -> If On
  • Pin 11 = ?
  • Pin 12 = GND

Sur la sortie 24v (1x12 pins)

  • Pin 1 = 24VDC -> Always On
  • Pin 2 = 24VDC -> Always On
  • Pin 3 = 24VDC -> Always On
  • Pin 4 = 24VDC -> Always On
  • Pin 5 = 24VDC -> Always On
  • Pin 6 = GND
  • Pin 7 = GND
  • Pin 8 = GND
  • Pin 9 = GND
  • Pin 10 = GND
  • Pin 11 = ?
  • Pin 12 = ?

Un dernier connecteur est présent sur l'alimentation, c'est une masse qui semble être dédié au 5V (elle est connecté à l'un des GND du SATA et à la carte mère).

On constate que cette alimentation ne fournis que du 12V et du 24V, aussi étonnant que ça puisse paraitre, c'est la carte mère qui se charge de transformer le 12V en 5V ! (le câble entre l'alim, la carte mère et le disque dur le confirme).

Il me reste donc le Pin 5 et 11 sur le port 12V et le pin 11 et 12 sur le port 24V qui sont un mystère (si quelqu'un a une idée, je suis preneur)…

J'ai trouvé le schema électrique d’une alim Liteon PE324101UN-LF (qui semble aussi utiliser dans d’autres iMac), il semble y avoir quelques infos, mais je ne peux que supposer l'utilité de ces pins…

Sur la sortie 12V (2x6 pins)

  • Pin 1 >>- +12V
  • Pin 2 >>- +12V
  • Pin 3 >>- +12V
  • Pin 4 >>- GND
  • Pin 5 >>- GND
  • Pin 6 >>- GND
  • Pin 7 >>- +5VS
  • Pin 8 >>- +5VS
  • Pin 9 >>- +5VS
  • Pin 10 <<- AC_DET (Alternating Current Detection ?)
  • Pin 11 <<- P_DIM (Power DIMming ?)
  • Pin 12 <<- BL (BackLight du LCD ?)
  • Pin 12 <<- PS_ON (PowerSupply ON !)

Sur les deux sorties 24v (1x12 pins)

  • Pin 1 >>- 24V
  • Pin 2 >>- 24V
  • Pin 3 >>- 24V
  • Pin 4 >>- 24V
  • Pin 5 >>- 24V
  • Pin 6 >>- GND
  • Pin 7 >>- GND
  • Pin 8 >>- GND
  • Pin 9 >>- GND
  • Pin 10 >>- GND
  • Pin 11 <<- P_DIM (Power DIMMING ?)
  • Pin 12 <<- BL_ON (BackLight ON ?)

Pour AC_DET, j'ai trouvé cette définition :

AC adapter voltage detection input. Valid AC adapter input range is set using resistors forming a voltage divider which are connected between ACDET & GND and ACDET & AC adapter.

P_DIM doit permettre de réduire la puissance de sortie des PIN 24V pour réduire la luminosité de l'écran ?

BL_ON, allumer le LCD ?

Bref, pleins de nouvelles interrogations.

Répondu ! View the answer J'ai le même problème

Cette question est-elle utile ?

Score 1
Ajouter un commentaire

Kits pour Nintendo Switch

Une solution rapide pour reprendre le jeu

Acheter un kit pour Switch

Kits pour Nintendo Switch

Une solution rapide pour reprendre le jeu

Acheter un kit pour Switch

12 solutions

Solution retenue

Bon, j'ai réussi à mesurer tout ce que je voulais.

J'ai fait un petit schéma pour ceux qui seraient intéressés.

S'il y a une erreur, n'hésitez pas à me le dire.

Block Image

Cette réponse a-t-elle été utile ?

Score 1

Commentaires:

/!\ ATTENTION /!\ , une erreur s'est glissé dans le schéma, il faut inverser le BL_ON et le P_DIM /!\

par

Ajouter un commentaire

Bonjour Thomas,

Première chose, j’ai fait une petite erreur sur mon schéma, il faut inverser BL_ON (BLO sur le contrôleur) et P_DIM (ADJ sur le contrôleur), c’est probablement ça qui produit le petit buzz électrique.

Pour l’alimentation, en se basant sur les pins de la prise CN102 de l’alimentation.

Il faut relier 3 (PS_ON) et 1 (GND) pour alimenter les pins 9, 10 et 11 en +12V.

Ensuite, tu peux relier par exemple le pin 11 (+12V) aux +12V de la prise CN5 du contrôleur (pas besoin de deux fils pour le +12 et le GND) et le pin 12 (GND) au pin GND de la prise CN5 du contrôleur.

Il faut également relier le pin 2 au pin BLO de la prise CN5 du contrôleur et le pin 8 au pin ADJ de la prise CN5 du contrôleur.

Pour la prise CN101 de l’alim, utilise le câble d’origine de ton iMac !

Pour la prise CN102, tu peux couper les fils de la prise d’origine pour faire quelques soudures fil à fil (fait ça proprement en isolant les fils !). Ou alors, récupérer une prise Molex sur une vieille alimentation ATX HS et couper les pins en excès (c’est ce que j’ai fait).

—————

Sinon, j’ai rajouté un convertisseur 12V vers 5V 3A :

https://www.ebay.fr/itm/6-Kinds-DC-DC-12...

Il est branché sur le pin 9 et 7, pour alimenter mon Raspberry Pi.

—————

Et enfin, j’ai rajouté un petit module de relais bistable : https://www.ebay.fr/itm/12V-1-Channel-La...

Je l’alimente avec pin 5 (+12V_SB, un 12V toujours allumé) et une masse (pin 6). De l’autre côté, j’ai mis le pin 3 et 1. Et comme déclencheur, j’ai tout simplement mis le bouton d’origine de l’iMac.

Comme ça, avec une pression sur le bouton du Mac, je démarre ou arrête l’alimentation.

—————

J’ai rajouté quelques subtilités dans mon projet :

• La sortie audio du Raspberry Pi est envoyée au contrôleur LCD (qui a aussi une piste audio avec amplification), pour alimenter les enceintes de l’iMac.

• Le Hifiberry est déporté du raspberry Pi avec une nappe pour mieux gérer la température de Raspi et que ça rentre dans l’iMac sans forcer.

• La sortie audio est dirigée vers des prises RCA que j’ai rajoutées à la place des sorties Jack de l’iMac.

• Je vais déporter le connecteur MicroSD derrière la trappe de la RAM de l’iMac (pour changer de système sans avoir à démonter).

• J’essaie de trouver une solution pour réutiliser les connecteurs USB et Ethernet de l’iMac (c’est la partie la plus chiante).

• Je vais tenter de piloter les ventilateurs de l’iMac avec les sondes de température de l’iMac à partir du Raspi.

Je ferais un petit article bien détaillé que je partagerais une fois que le projet sera totalement terminé. ;)

Cette réponse a-t-elle été utile ?

Score 1
Ajouter un commentaire

Normal, tu fais un gros court circuit sur ton 24v !

Regarde bien mon schéma, CN101, pin 1 à 5 = +24V, pin 6-10 = GND !

sur ton schéma, tu envois en GND où il devrait y avoir du 24v, du coup, mauvais !

C’est pour ça que je te dis d’utiliser le câble d’origine et de brancher le BLO (du contrôleur) sur le pin 2 du CN102 et le ADJ sur le pin 8 (qui sont des « ponts » vers les bon pin de l’ecran.).

Cette réponse a-t-elle été utile ?

Score 1

Commentaires:

OK merci. Bon en vérifiant, je ne crois pas inverser +24V et GND. Mais j'ai mal du faire mon schéma. Je vais tout de même refaire le branchement en utilisant le câble d'origine. A suivre !

par

Salut Thomas, j'ai fais le shéma électrique de mon projet, avec ça, tu ne peux pas te tromper : https://share.remy-photographie.com/stor...

par

@mrsoul Grand merci, quel dommage je n'ai pas vu ta réponse avant ce soir. Ici toujours le buzz de l'alim, mais je vais encore bien vérifier avec ton nouveau super schéma. Sinon, pour l'alim, que faudrait-il vérifier avec un multimètre, pour savoir si elle n'est pas simplement défectueuse ?

Merci en tout cas.

par

Ajouter un commentaire

@isidoreisou, effectivement, ce bruit n’est pas normal.

Je ne suis pas expert, mais quelques points à regarder pour savoir si il y a un problème sur l’alim.

  • Tout d’abord, quand elle est alimenté, sans aucune connectique, fait-elle toujours le bruit ?
  • Si le pin 1 et 3 sont connecté, fait-elle toujours le bruit ?
  • Si elle fait du bruit uniquement quand quelque chose est branché dessus, ça ne vient probablement pas de l’alim.

Sinon, vérification visuelle (à faire alim éteinte !) :

  • Regarder si un condensateur est gonflé (auquel cas, le changer, c’est facile).
  • Regarder si les soudures sont bien faites (parfois, ça se désouder), auquel cas, les refaire, c’est facile.
  • Regarder si il y a une trace de brulé, ou une odeur suspecte.

Enfin, on peut tester l’alim, attention aux court circuit (alimenté, rien connecté sauf le pin1 + 3) :

  • Tu met ton multimètre en position voltmètre DC (courant continue), bien choisir le range si il ne la sélectionne pas automatiquement. Tu met la borne COM (GND, -, négatif, noir) de ton multimètre sur une masse (Pin 1, 6, 7, 12 du CN102 ou 6, 7, 8, 9, 10 du CN102) et tu met la borne INPUT (+, rouge) de ton multimètre, sur les pins 5, 9, 10, 11 du CN102 qui doivent sortir du 12V (ou très proche), puis sur les pins 1, 2, 3, 4, 5 du CN102 qui doivent sortir du 24V.

Une fois l’alimentation non alimenté :

  • Faire un test de continuité entre le pin 2 du CN102 et le pin 11 du CN101, ainsi qu’entre le pin 8 du CN102 et du pin 12 du CN101.

Avec ça, tu devrais déjà en savoir plus.

Cette réponse a-t-elle été utile ?

Score 1

Commentaires:

Merci de vais regarder ca.

Ce qui est sur, c'est que l'alim fait ce bruit uniquement quand le LCD s'allume, donc cela vient probablement du 24V. Ou alors comme tu le dis, cela ne vient pas de l'alim.

par

Bon, j'ai testé l'alim, tout semble OK.

Tu peux juste me dire ce que tu veux dire avec cette phrase : "Si elle fait du bruit uniquement quand quelque chose est branché dessus, ça ne vient probablement pas de l’alim ?" Merci @mrsoul !

par

J’ai un peu ma réponse…

Si tu alimente l’alim, mais que rien n’est branché sur ses connecteurs, elle ne fait aucun buzz ?

* « J’alimente

* Le contrôleur s’allume vert, le rétroéclairage s’allume, et le buzz commence. »

*

En relisant ça, je vais encore une fois te proposer d’intervertir le BLO et l’ADJ, tu risque rien si tu ne le laisse pas allumer longtemps.

par

Si j'alimente l'alim est que rien n'est branché, pas de buzz.

Des que le LCD s'allume = buzz, quand il se met en veille car rien branché sur le HDMI, buzz off.

Si j'intervertis BLO et ADJ, pas d'image sur le LCD. J'ai vérifié 5 fois, le câblage est bon.

Mais bon, vu que cette série d'iMac est connu pour avoir des buzz d'alim, j'imagine que c'est le cas ici. super frustrant après tous ces efforts !

Merci !

par

Oui, je viens de voir que le problème était connu.

Vérifie quand même juste que le bruit provienne de l'alimentation ou de l’inverseur (l'alimentation du rétroéclairage qui est fixé sur l'écran).

Je pense que remplacer l'alimentation est trop couteux (les tarifs que je peux voir sont autour de 170€), sinon, tu peux aussi essayer de la remplacer par un alimentation de télévision (qui a du 12 et du 24V), ça coûte dans les 30-40€, proposé par la boutique qui m'a vendu le contrôleur LCD, mais il faut que tu étudie bien la question pour voir si ça rentre dans le boitier.

Dernière option, tu semblais dire que ça venait de l'inductance (la bobine), tu peux essayer de la remplacer (je ne promet rien).

J'ai aussi trouvé ça pour toi :

So how can this audible noise be reduced?

Apply a liquid varnish or RTV Silicone 190 to coil if the inductor is soldered on board.

par

Afficher 1 commentaire en plus

Ajouter un commentaire

Hello @mrsoul

Je suis extrêmement heureux de lire vos messages, car j’essaye moi aussi de recycler un iMac A1225.

De mon côté, j’essaye d’alimenter mon contrôleur LCD, en 12V, avec l’alim de l’iMac. Je peux déjà utiliser le tout en alimentant le contrôleur avec une prise 12V style disque externe, mais j’aimerais l’alimenter avec l’alim de l’iMac.

Mon contrôleur a besoin de 2x12V et 2xGND.

EDIT: Mon contrôleur a besoin de 12V, en 2 fils rouge et 2 fils noir.

Je ne suis pas aussi calé que vous alors voici quelques questions :

  • Si je branche, depuis le connecteur 2x6V, les pin 9+10 > 12V, et les pin 6+7 > GND, cela vers mon contrôleur LCD, je suis bon ?
  • Dois-je faire un pond entre les pin 6 et 4 ? (c’est à dire les connecter ensemble ?)
  • L’alim de l’iMac fonctoinne, elle arrive à alimenter l’écran, il s’allume etc. Par contre elle fait un petit bruit constant, un buzz. Une idée de comment corriger cela ?

Grand merci !

Cette réponse a-t-elle été utile ?

Score 0

Commentaires:

Je t'ai mis la réponse juste en dessous, ça ne passais pas en commentaire

par

Ajouter un commentaire

Grand merci pour ces précisions.

En 2 mots, j’ai fais les branchements, ca marche, l’écran s’allume et le contrôleur LCD aussi.

Mais toujours ce buuuuzzzz de l’alim… dommage.

Je ne sais pas si l’alim faisait ce bruit avant de démonter l’iMac.

La seule chose que je n’ai pas fais comme tu me l’as conseillé, c’est ça :

Il faut également relier le pin 2 au pin BLO de la prise CN5 du contrôleur et le pin 8 au pin ADJ de la prise CN5 du contrôleur.

Ces 2 connections, elles viennent de la prise qui se trouve sur le panneau LCD.

Ca fait :

CN5 ADJ > LCD pin 13

CN5 BLO > LCD pin 12

J’ai suivi les instructions du manuel de ma carte contrôleur.

Une idée d’où ce Buzz peut venir ? Mon alim est-elle défectueuse ?

En tout cas, fais bien un guide après ton projet, car ca à l’air TOP !

Merci.

Cette réponse a-t-elle été utile ?

Score 0
Ajouter un commentaire

Dans ton cas (et c’était aussi le miens), si tu regarde bien, quand tu alimente le tout, le contrôleur s’allume, la diode passe au vert et l’écran semble allumé, mais il n’y a pas de rétroélairage. Si tu presse la touche d’arrêt du contrôleur, la diode passe au rouge, l’écran semble s’éteindre, mais si tu regarde derrière, le rétroéclairage s’allume (et tu as ce bruit de buzz bizarre).

C’est tout simplement que le BLO et le ADJ sont inversé !

Inverse les deux, tu n’auras plus ce bruit et surtout, tu auras enfin le rétroéclairage de l’écran (avec l’affichage du menu ou de ta source vidéo).

J’ai d’ailleurs vérifié pour être sûr, le CN5 BLO est bien en continuité avec le pin 13 de l’alimentation de l’inverseur.

Cette réponse a-t-elle été utile ?

Score 0
Ajouter un commentaire

Merci pour ta réponse,

Malheureusement je ne crois pas que ce soit la même chose chez moi :

  • J’alimente
  • Le contrôleur s’allume vert, le rétroéclairage s’allume, et le buzz commence.
  • Le menu de l’écran est affiché, ou la source HDMI si j’ai quelque chose de branché.
  • Puis, si l’écran passe en veille, le contrôleur passe au rouge, le rétroéclairage est OFF, et le buzz s’arrête.

Je vais continuer de chercher au niveau de ce BLO et ADJ… mais je sèche un peu.

Cette réponse a-t-elle été utile ?

Score 0
Ajouter un commentaire

Et pas de problème au niveau du rétroéclairage, tu vois bien l’image ?

Le bruit électrique vient d’où exactement ?

Alimentation du Mac, contrôleur LCD, inverter (la petite carte collé derrière l’écran), écran ?

As-tu un multimètre pour faire quelques tests de continuité, test de voltage ?

Cette réponse a-t-elle été utile ?

Score 0
Ajouter un commentaire

Aucun problème de rétro éclairage. L’image a juste une tonalité très très chaude, pour l’instant.

Le bruit bient de l’alim, des petites bobines de cuivre.

Et pas encore de multimètre, mais je ne saurais pas quoi mesurer.

Je vais dessiner un plan de mon montage dès que jai le temps afin de voir si je n’ai pas fait d’erreur.

En tout cas, l’iMac avant le démontage n’avait pas de bruit d’alim, je viens de demander à la personne qui me l’a filé. Par contre il ne fonctionnait plus (image noir), je soupçonne carte graphique HS.

Cette réponse a-t-elle été utile ?

Score 0
Ajouter un commentaire

Block Image

Block Image

Voici une image et un schéma de mon iMac.

Comme on peut le voir, à certains branchements, j’ai des fils en trop. Je ne sais pas si ca peut causer ce buzz. Mais je ne pense pas.

Je me dis, naivement, que ce “buzz” peut venir du fait d’avoir mal branché quelque chose à la terre. Comme quand l’on branche mal une platine vinyl. Mais j’ai pourtant bien relié la prise terre au niveau de la prise femelle d’alimentation de l’iMac.

Dommage ce buzz j’y suis presque !

Merci !

Cette réponse a-t-elle été utile ?

Score 0
Ajouter un commentaire

ReBonsoir @mrsoul ,

J’ai revérifié les branchements avec votre dernier schéma. Tout fonctionne, l’écran s’allume et j’ai l’image du HDMI sans problème. Par contre, toujours ce buzz d’alim, je l’ai même enregistré : https://vocaroo.com/i/s1h8IJA2hBOo

Merci pour toute cette aide.

Cette réponse a-t-elle été utile ?

Score 0
Ajouter un commentaire

Ajouter une réponse

MrSoul sera éternellement reconnaissant.
Afficher les statistiques:

Dernières 24 heures : 1

7 derniers jours : 6

30 derniers jours : 29

Total : 529