Aller au contenu principal

Réparez vos affaires

Droit à la réparation

Boutique

24" display; Built-in iSight Camera, Microphone, and Speakers; 1920x1200 resolution. Released October 2008, identified by model number A1267.

Questions au sujet de 84 Voir tout

Backlight issues here's how I fixed mine!

@John &Io Nut

I have an LED cinema display 24" from 2009, I have excatly the problem that the screen blanks out after a 1 sec flash of the image (probably LED driver signal turns down). I was about to try the bypass solution above for the 3.3V drive input, but then wanted to ask first if the same backlight strip probem problem could be on my LED Display as well, because I would not want to loose the dispay dimming possibility.

update:

So I did take the LG LCD panel apart in search for the notorius LED Strip, see pictures:

Block Image

Taking the LCD apart:

The LCD frame,

Block Image

The Backlight panel,

Block Image

The plastic frame,

Block Image

Block Image

The glass of the panel,

Block Image

The back plate,

Block Image

Finally getting down to the LED Strip

Block Image

So I did resolder the LED connector (just added some solder to it and re-heated the 5 pins again thoroughly), but my problem still persists, the LED stripe only flashes quick at connection display port connection time. I am considering of doing some logic measurements tonight with my oscilloscope for the LED driver, but the willi fix for bypassing the 3.3V is starting to sound tempting (still trying to find out the real reason for this failure, and I have to admit that the LED stripe fault sounds more plausible to me due to the drive signal LED shutdown after one second flash.

Update (23.02.2017)

@io nut

I made some advancements with the display but the reason for the fault is still unclear.

All of a sudden the LEDs decided to turn on again.

Block Image

I am convinced that it has something to do with the horizontal positioning of my setup. While lit I quickly checked the LEDs and realised that Led nr. 27,30,40 and 60 are out. Next day when I started the display the background lighting did not lit again.

I figured it might have something to do with grounding and tried out connecting the displayport without the USB cable. No effect the LEDs turn on with or without the other USB connector and/or the Powerconnector. I realised that the LED cinema display brightness can not be adjusted without the USB cable connected to the my macbook pro.

Block Image

Update (26.02.2017)

LED illumination pattern 2/3 Leds.

Block Image

LED illumination pattern every third LED

Block Image

Update (27.02.2017)

So after all the MODs my display is running again. Eventually I ended up only changing 9 capacitors (3 pcs of each of the black ones in the pic, the orange ones I still have originals) on the powersupply,

Block Image

and resoldering the LED stripe connector,

Block Image

in addition I assembled and reassembled the display several times (loose connectors).

So Im still not convinced about the source of the fault and Im now testing the display for a week, lets see if it actually stays on.

Update (05.03.2017)

My Apple LED Cinema Display 24" is still up and running.

Update (03/22/2017)

Unfortunately I have to report that my LED cinema display died again after one month of fluent usage. So Im back to square zero. :!

Update (15.05.2017)

I decided to try out if my display runs and it seems to run again :). So lets see for how long, but I am suspecting some sort of capacitor voltages that are incorrect due to capacitor ageing.

Répondu ! Afficher la réponse J'ai le même problème

Cette question est-elle utile ?

Indice 5

Commentaires:

Robert, excellent pictures !

If you are absolutely sure you have resoldered properly the connector, and the symptoms are the same that means the problem must originate somewhere else. Your symptoms are different from the ones I have experienced, but it definitely sounds like a detected fault triggers the backlight to shut down. (is it just the backlight that shuts off?- do you have an image on lcd if you shine a light on the lcd?)

Does the whole strip light up during that 1 second? Noticed any LED stay unlit?

Is the octopus cable ok? Tried different one? (Yours could short out, like mine did initially).

Cover all your bases and now that you got so far, do not rush ! Ultimately, try the bypass mod, but in a non-destructive way, so you can undo it if necessary.

par

Thanks for the rapid answer. I basically ruled out the octopus cable malfunctioning because I actually managed to start the monitor, but only the first time. So I got a nice and bright (with backlight) picture, but as soon as I restart the monitor the backlight just blinks and then shuts down again, probably some capacitor malfunctioning in the Logic board.

I did not realise any dark LEDs during the very brief flash of the LEDs (cant say for sure though). So I basically now have the monitor open and plain LEDs connected to the Logic board.

I ll try to get another octopus cable somewhere to try out, I havent tried that yet. Though I think the cable is not the fault since I have succesfully turned on the monitor 3 times (always after a long break or disassembly to let the charges out).

How would you do the bypass in a non destructive way? I mean once I have the resistors out it could be quite a challenge to get them back into their places.

par

Non destructive way, meaning do not cut traces or destroy the 0 ohm resistors when you take them out. Use two fine tip irons ( or one tweezer tip preferably) and heat up both ends of the resistor at the same time and lift it off the board. Save it on a sticky tape in case you need to put it back on. Solder it back the same way, but use some flux on the pads. It is easy.

par

I am assuming, you have done the firmware update for both the monitor and the macbook...?!

par

I am actually running an old macbook pro mid2010 15" OSX 10.9.5 so it still has a display port instead of thunderbolt port, the firmware update I found would not install saying "your computer does not need this update " propably due to the fact that I have a display port instead of the never thunderbolt port.

I also tried the Macbook pro of my girlfriend, mid2010 13" running a OSX 10.11.6 El Capitan.

par

Voir 3 commentaires en plus

Ajouter un commentaire

4 solutions

Solution retenue

Update (2018/09) My display is still up and running after changing the Capacitors, but I reckon this is only coinsidense. I would advice you to have a look at James Stuart comment/explanation below. I think it makes the most sense and explains the cause of the problem well!

Update (06/14/2020)

I got some more equipment and returned to fix my 24” cinema display. So in the meanwhile the display was working like every second day by chance. In the meantime I found a donor cinema display with the same defect. Backlight shutdown after a flicker of light.

So I decided to open my display again and took out the led strip totally to test it. I only have a 30V regulated power source so I could test the whole led array (60Volts needed). But I tested the leds individually and they seemed to at least light all one by one with significant differences in luminousity. Now I wonder how to find out which ones should I replace without desoldering all of them. I desoldered 4 of them with my new hot air station, but it is quite tedious to get one out.

Update (06/14/2020)

Block Image

Block Image

Block Image

Block Image

Block Image

Update (24.07.2020)

Block Image

I found the Lumileds to order, but investing like 130CHF (approx. 130USD) is a bit too much for the moment, for this project. Besides I tried unsoldering with hot air station that I ordered a few of those LEDs and it is indeed possible but quite tedious, so perphaps not worth the time and money.

Update (08/08/2020)

  1. Everlight ELSH-J11N(X) seems to be a pretty close to identical product to these Lumileds.

The best match in alibaba that I found to replace the LEDs.

LED lighting ELSH-F91N1-0CPGS-C4500 SHUEN NEUTRAL WHT 4500K 2SMD

https://www.alibaba.com/product-detail/L...

Cette réponse a-t-elle été utile ?

Indice 2

Commentaires:

There is mention of a comment from John Stuart but I don’t see it anywhere?

par

Ajouter un commentaire

I have now changed the LED bar from a donor Cinema display and it works like a charm since a week already. It always starts immedeately and the display is dimmbar normally.

LEDs age, and as such the amount of light that is emitted reduces. The LED’s in the LM240WU6 panel are made by LumiLEDs which is a subsidiary of Philips who in turn produced the panel under license from LG. The LEDs used are LXML-PWN1-0120 which should be operated at a forward voltage of between 3.0V & 3.6V @ 350mA and have a stated 39000 hours of life.

The LED strip has a sticker on it:

  • P1803001D
  • P66L01746

Cette réponse a-t-elle été utile ?

Indice 0
Ajouter un commentaire

In another thread one poster suggested that removing R1135 on the logic board is a dirty fix that would bring back light to Cinema display with black screen problem. I simply can’t find where it’s located on Cinema 24”.

Cette réponse a-t-elle été utile ?

Indice 0

Commentaires:

I think they are talking about a part on the 27" cinema display as that board looks different then the one on the 24". I too looked all over my 24"s board and did not find the part.

par

Ajouter un commentaire

I have the same issue and i suppose the problem is the led strip, can you please help me what led strip to order? Can you give me link? My model is Apple A1267, thank you

Cette réponse a-t-elle été utile ?

Indice 0

Commentaires:

I have not been able to source the LED strip part anywhere, using these part numbers (P1803001D T4B501536) . P1803001D must be part and the other is SN. Nothing as well for more generic strip (60 LED, 525mm, 6 pin...). I have had a bunch of these displays fail, and the only thing that worked for me after eliminating logic board or PS is replacement with a working panel. Once in awhile, they come up at a reasonable price used on eBay. Spending hundreds on new panel from China never was something I could justify. Taking apart is not a huge issue so replacing just a strip seems like it would be worthwhile. I have a LED power supply tester, but have not been able to figure out which pins light the entire strip - most I can get is every third LED. I do not have a working strip to compare to. I have noticed that the plastic cups over the LEDs are quite brittle and tend to detach very very easily, so this may be due to long hours and insufficient heat dissipation. The LED strip is screwed to the bottom frame with what I think is thin blue heat transfer tape.

par

Did you manage to find an alternative LED strip? I think I have the same problem, but have only managed to find 60LED 525mm long strip with 8pin connector, or 64LED 530mm long strip with 6pin connector. But it looks like the arrangements of the pins is different t the original.

par

Looked again for replacement LED strip. Nothing. I now have 2 dead panels following replacement with working panels I bought on eBay. Hate to just throw them out knowing 'somewhere' out there, there are $20 strips that would work. I will keep them until the next basement purge, and if nothing turns up to repair, they will go to e waste. At least I have 2 working cinema displays that were repaired for about $80 each.

par

Ajouter un commentaire

Ajouter une réponse

Robert Nawfal sera éternellement reconnaissant.
Afficher les statistiques:

Dernières 24 heures : 2

7 derniers jours : 23

30 derniers jours : 168

Total : 4,024