Aller au contenu principal

Réparez vos affaires

Droit à la réparation

Boutique

1.7 GHz dual-core Intel Processor (Turbo Boost up to 2.6 GHz) with 3 MB shared L3 cache

Questions au sujet de 151 Voir tout

Keyboard and Trackpad unresponsive, liquid damage on logic board

I bought a MacBook air with unresponsive keyboard and Trackpad. I was told it had not suffered liquid damage, so I thought it'd probably be a case of replacing keyboard and or Trackpad with ribbon, but off course when I opened it up, I noticed there were some liquid damage marks underneath the logic board.

I cleaned this out with isopropyl alcohol and left it to dry. I can't see any resistors etc missing off the board. Connectors also look ok visibly. Put it back together and still the same issue.

I know the issue is on the logic board as I've tried another board from a similar MacBook and keyboard and Trackpad came to life.

I'm looking for some advice as to where exactly on the logic board should I be looking for any particular issue relating to the Trackpad/keyboard please?

Picture of cleaned up logic board is attached.

Block Image

Block Image

Thanks

Répondre à cette question J'ai le même problème

Cette question est-elle utile ?

Indice 0

Commentaires:

Can anyone help?

par

What is the board model number?

par

Hi

It's 820-3208 A

par

@optimizelogic are you able to assist with this logic board issue? Thanks

par

Before you cleaned the board, did you notice any corrosion anywhere?

par

Voir 5 commentaires en plus

Ajouter un commentaire

1 solution

Agreeing that you have expertise in hardware swapping and also assuming software expertise, reinstall all the parts and perform the clean install of the MacBook using a USB keyboard and mouse and perform clean OS X install as it might suffered kernel panic or kernel extension problem. Before reinstalling clean the connectors of the trackpad and keyboard in the logic board with ipa. All the best

Cette réponse a-t-elle été utile ?

Indice 0

Commentaires:

Ravi - how is reinstalling all of parts back together going to fix a hardware fault? All connectors have been cleaned and I've put it back into machine and have also tried a new SSD with OS installed prior to posting the question.

Clearly it's a hardware fault with the logic board but I am trying to identify what I need to check on the board to fix the issue.

By the way I've just done that again anyway, put it all together and reinstalled MacOS, as expected not had any impact.

par

Ajouter un commentaire

Ajouter une réponse

Faisal Gondal sera éternellement reconnaissant.
Afficher les statistiques:

Dernières 24 heures : 0

7 derniers jours : 0

30 derniers jours : 1

Total : 91