Aller au contenu principal

IMac Intel 27 ". EMC 2309 (fin 2009, Core 2 Duo 3.06 ou 3.33 GHz), EMC 2374 (fin 2009, Core i5 2.66 GHz ou Core i7 2.8 GHz)

Questions au sujet de 523 Voir tout

Broke vertical sync cable on reinstall... possible fix?

Hello everybody,

While reinstalling my display into my iMac, I broke one of the 4 thin strips of metal that comes out of the vertical sync cable. I only noticed this after restarting the computer and hearing a weird high-pitched ringing noise (and researching the issue, apparently this is a problem on many stock iMacs). The display itself appears to work fine, so I don't want to make things worse, but is it possible to cut the cable and strip the protective coating, making the cable viable again?

Thanks!

Répondu ! Afficher la réponse J'ai le même problème

Cette question est-elle utile ?

Indice 3

Commentaires:

Here is part I saw on Ebay http://www.ebay.com/itm/391220999040?_tr...

Thanks,

Kal

par

Took my late 2009 27" imac to the shop for hard drive issues and it failed so I decided to fix it myself and noticed a flashing folder when i started it up after stuffing that small connector in it's spot. I knew something was wrong but i put it together anyway...Didn't work so I opened it again and noticed that one of the tiny contacts was peeled back. I bent it back and re assembled it. I also found plenty of spare and NEW parts # 539-1049 v online @ eBay some for $6.00 free s/h. Make sure you buy the right kind mine ends with a "v" not "A"... But Yes they can be fixed and you'll need the right kind of tape Kapton tape. This tape is heat sensitive made for computers.

par

Ajouter un commentaire

8 solutions

Solution retenue

After finding the part online (about $20 USD, not too bad) I decided I could mess around with the cable - I mean it's broken anyways, right?

So I cut off the part that was broken (all of the exposed part) and stripped away the other half of the end (the cable is stiff at the end, and half of that part is the original exposed part). Plugged that into my computer (with the hacked part monitor-side to make insertion and removal easier in the future) and it works! No high-pitched whining :)

Cette réponse a-t-elle été utile ?

Indice 7

Commentaires:

+ Thank you for coming back with the answer. I have never attempted to do what you were asking. It is good to know it is something that can be accomplished. By the way where did you find the part?

par

The cheapest available part was here: http://www.usedmac.com/catalog/product_i...

par

Could you please elaborate further on how you did this? I have to do this after upgrading my hard drive also and have literally the same problems and same computer!

par

Craig you will get the attention you need and deserve by posting your own question about this

par

I really don't understand his proceeding, I'll have to try it my way some day.

par

Voir 3 commentaires en plus

Ajouter un commentaire

Hi, I had the same problem after installing a SSD instead of the optical drive. The pins of the vsync-cable were not broken but bent. The first day after the upgrade everything seemed fine, but on the second day the display went black. I opened up the imac and pulled the vsync out of it's slot and left it this way. At the moment everything seems to be all right again. Hope it lasts...

Best regards

Christof

Imac 27 inch, late 2009

Cette réponse a-t-elle été utile ?

Indice 2

Commentaires:

I had a similar issue with my mid-2010 27" iMac. Broke the connector and just left it. Then closed it up. Is there a problem with not having this cable attached?it seems to be working just fine.

par

Ajouter un commentaire

These original posts are 9 years old but I resurrected my 2011 mac. I must have gooched this little vertical sync cable when i removed it. I stripped it down by gently pulling back the tiny plastic tabs holding the wires in the connector. I didn’t do anything special, just jiggled them around a bit (that’s the technical term) put them back in again and lo and behold it worked. Thanks you for giving me the idea to do this people.

Cette réponse a-t-elle été utile ?

Indice 1
Ajouter un commentaire

Hi there, i bought a used 2009 imac 27 inch and when i replaced the hdd with an ssd i noticed that the v-sync cable was missing from the display so i normally ordered on online but i can’t find where to connect it on the back of the display. Can somebody tell me where the display connection is?

Cette réponse a-t-elle été utile ?

Indice 0

Commentaires:

Check this step of the related guide: Remplacement de la carte AirPort de l'iMac 27" EMC 2309 et 2374 You can't really see where it plugs into the display but you can see where the cable goes.

par

Ajouter un commentaire

Hi,

Anytime an imac breaks down no matter what age as long as it’s not too old it can be fixed , at home. I found out that those cables don’t really matter that much to the computers performance, but if you have to upgrade or go back into your computer, you can order any parts for an imac now on eBay or a Mac parts online store. Plus there are tons of YouTube videos to guide you through the repair.

Cette réponse a-t-elle été utile ?

Indice 0
Ajouter un commentaire

Just to resurrect this old thread, I’ve just updated to an SSD in my late2009 21 1/2” imac, (yes, it was still running the original HDD!).

I have fat fingers and it took me ages to get it to run again. Anyway, I had exactly the same issue with the vertical sync cable. Bent wires which I managed to straighten again and hey presto!

I can actually dismantle the thing with my eyes shut now. :-)

Cette réponse a-t-elle été utile ?

Indice 0
Ajouter un commentaire

Hi,


I just replaced my HDD in my late 2009 iMac with a new SSD. I followed a couple of different guides on how to do it. After I was done, I tried to turn on the mac, and it made the startup chime, and the screen turned on (I'm assuming because it went from black to gray). However, when I try to boot it with Command, Option + R + P or any of the other combinations, nothing happens(The screen just stays gray.)

I thought it was a problem with not having a bootable macosX version, so I used my Macbook to setup a bootable macOS High Sierra USB Install drive. I then plugged it into the iMac and used Option + R, but still the screen just stays gray.


I double checked all of the cabels, and they are in, but when I was putting (What I think to be either the V-sync or lcd cabe) it was a bit finicky.


Any help would be greatly appreciated!


Cette réponse a-t-elle été utile ?

Indice 0
Ajouter un commentaire

The V-sync is the first one to try and yes, it is a PITA!

Some have just left it disconnected but I managed to flatten the contacts back out and separated them. Still has a little grumble mid-startup but no more grey screen.

Just be sure the LCD cable is installed correctly too.

Cette réponse a-t-elle été utile ?

Indice 0
Ajouter un commentaire

Ajouter une réponse

Adam Hintz sera éternellement reconnaissant.
Nombre de vues :

Dernières 24 heures : 3

7 derniers jours : 22

30 derniers jours : 100

Total : 23,720