Aller au contenu principal

12.1" netbook released in September 2010. Powered by an Intel ATOM D525 dual core processor running at 1.8 Ghz and NVIDIA ION graphics processor.

Questions au sujet de 4 Voir tout

No power ON after replacing LCD

The same problem of other users that replaced some component of the netbook.

In my case my Asus 1215N refused to power on after I replaced the broken LCD panel with a new one. Once I completed the substitution, I attached the LCD panel to the flat cable and rescrewed it to the cover. Then I powered on the netbook and the display worked as expected.

Then I connected the plastic cover to the based unit rescrewing the lid to the hinges of the base unit. The hinge on the right side was locked so the screws on the right side were unuseful to connect the lid to the base unit and the lid was swinging on the right. I tried to turn on the power switch again, but it didn't light and the netbook didn't start. Some guys suggested to held the power switch for about 50 seconds, disconnecting the battery and the power supply before and so I did, but nothing changed. I reconnected battery and tried to press power switch again, but the netbook didn't start.

Is it possible that some cables have come loose?

In these cases what kind of checkes do you suggest?

Répondu ! Afficher la réponse J'ai le même problème

Cette question est-elle utile ?

Indice 0
Ajouter un commentaire

1 solution

Solution retenue

If it worked as you stated in the beginning of your discription then yes you later disturbed a cable or possibbly shorted something - like wrong screw in wrong hole. Recheck.

Look at one of the disassemble videos several times. I would go back to the stage where you had it working.

Then reassemble SLOWLY, frequently pausing to look carefully at everything. If you do this I’m sure you will see what you missed or did.

Cette réponse a-t-elle été utile ?

Indice 1

Commentaires:

Many thanks. I'll try.

par

I checked all the actions I made to replace the LCD panel. The only more operation I performed was to unscrew the lid from the hinge that connects the cover to the base unit. When screwing it back on, the cover came off completely from the right hinge, located in proximity of the Power On button. Is it possible that some of the cables came off at that stage? What have I to check? Do I have to open the base unit?

par

@giannidep Yes of course. As it wont power on look around the power button and associated cables. Look for loose wires, etc. I'm not very clear about what you describe about the right hinge but recheck out that again.

All kinds of things can happen when disasembling or re-assembling thus do it slowly taking frequent breaks to study. Only what you did the first time. Remember it is an action that you did that caused this problem. So review.

Good luck. You will figure it out. We are here to help and guide you but you have to do it.

par

Ajouter un commentaire

Ajouter une réponse

giannidep sera éternellement reconnaissant.
Nombre de vues :

Dernières 24 heures : 0

7 derniers jours : 0

30 derniers jours : 1

Total : 33