Aller au contenu principal

Lancé le 4 novembre 2017. Modèles A1868, A 1901. Disponible avec GSM ou CDMA /  64 ou 256 Go / argent et gris sidéral. (Se prononce "iPhone 10".)

1195 questions Voir tout

Kernel Panic: What & where is the TP1A sensor?

Something happened to me when I was repairing the iPhone X

I damaged a piece of the main camera's FPC connector and in the upper left corner of the main circuit board a piece of the plating is gone (copper shows through).

The device works perfectly except for one error that I couldn't find anything about on the Internet: A kernel panic with thermalmonitored error and missing sensor TP1A

I couldn't find anything about the TP1A. It will probably be near the camera connection? After unplugging all components, the error still occurs and the device restarts every 3 minutes. But there was a short time when loading, the device didn't restart for 1 hour?

In a Chinese forum, the battery is listed as the error description for the TP1A, without further information on it. Is that correct? The built-in battery is already too "old" (1000 cycles with 82% capacity) anyway, but it still worked without any problems. Does it have to be flushed out? I'd rather have it than something to do with the logic board ;)

Could someone enlighten me more about the TP1A?

Répondre à cette question J'ai le même problème

Cette question est-elle utile ?

Indice 1
Ajouter un commentaire

2 Réponses

Réponse la plus utile

So if it's not any of the usuals, it could also be that there is a board level issue preventing the flash sensor from communicating. there are some components related to that data in that area, I don't remember what the identifier for that sensor is in the logs.

A little digging makes me think that TP1A might also be related to one of the thermistors that are on the board. I have never fussed with them to know if they cause those same sort of 3 minute panic issues, but it's would make sense. One of them is located at the top right of the "wide" camera connector, which is the top one of the two. I think that's the one, you are referencing? They may be covered over by some silicone or other sort of protection. I don't have iPhone X board hand to check. Anything around connectors usually is, but if you peel away that coating I wonder if both the resistor and the capacitor here are intact. There are a couple other places those show up on the board, but this one makes the most sense.

Block Image

Uploading some pictures of the damage you're looking at could certainly help point us in the correct direction as well. Which pin on the camera connector is the one that's the issue?

What was the initial problem you were fixing?

Cette réponse est-elle utile ?

Indice 2

1 commentaire:

This is the correct answer. Had the same panic log on an iPhone 8, so inspired by this comment I took a look at my FOREHEAD_NTC (same as the picture) line. Lo and behold it was grounded. Changed the cap and the resistor and the phone works normally again!

par

Ajouter un commentaire

This error is caused by a faulty charge port. It has nothing to do with the camera. You will need to replace the charge port. Make sure you purchase one from a reputable store.

Cette réponse est-elle utile ?

Indice 1

8 commentaires:

No, unfortunately I have to disappoint you. This is not an run-of-the-mill thermald error where the dock flex or the flex from the flash, power button is the culprit. The TP1A has nothing to do with it either and is located somewhere else. Otherwise the error could be corrected or the TP1A could be found more often on the Internet? I don't know.

As already mentioned, all components were disconnected and the logic board was tested in this way. I also tested all run-of-the-mill sources of error myself (except Battery) and tested 2x Powerflex and 3x Dockflex's or Lightning ports, with the same result.

Anyway, thanks for the answer

par

@Hello Have you tried using iDevice Panic Log Analyzer? You can find it at Github.

par

@imicrosoldering Yes, but the program only outputs the usual ones, i.e. Dockflex and Powerflex. It's probably a placeholder if thermaldd and missing sensors are mentioned in the log beforehand. It's usually just that, but for me it's just different circumstances. I would like to know where the TP1A is installed. In the Chinese forum, the sensor says battery error, but you never know. I ordered a battery, but it will take a while before it arrives.

par

@Hello The Chinese make all the parts so they should know. If you remember let us know the outcome.

par

@imicrosoldering I just do not know how to go on.

Exactly the same with a new battery. Crash and missing sensor TP1A, but only when iPhone unlocked after restart. If it stays locked then there is no kernel panic.

I noticed that the flash stopped working. Neither with the original nor with the OEM power flex. The main camera doesn't work anyway because I broke the connector and 1 gold contact is missing. The zoom camera works wonderfully.

Does the flash not work because of the main camera? Or is something different? If the TP1A is on the powerflex, maybe the flash doesn't work because I've damaged traces on the logic board?

Didn't want to break anything either, happened to me when turning a screw into the frame and sanded the logic board up a bit with the screwdriver.

Can anyone tell me where the sensor is installed?

Can I throw the logic board in the trash?

I just do not know how to go on...

par

Voir 3 commentaires en plus

Ajouter un commentaire

Ajouter une réponse

Hello sera éternellement reconnaissant.
Nombre de vues :

Dernières 24 heures : 3

7 derniers jours : 32

30 derniers jours : 100

Total : 2,270