Aller au contenu principal

Processeur quad-core Intel Core i7 à 2,2 GHz (Turbo Boost jusqu'à 3,4 GHz), 2,5 GHz (Turbo Boost jusqu'à 3,7 GHz), ou 2,8 GHz (Turbo Boost jusqu'à 4,0 GHz) avec 6Mo de cache L3 partagé.

774 questions Voir tout

Keyboard Issues - Ghost Scrolling - Can't Reset PRAM

I have a Mid-2015 15" Retina MacBook Pro. The user complaint was something to the effect of the "trackpad is behaving weird". Based on that I suspected maybe it was a swelled battery issue or faulty trackpad which I have seen before. But it is none of those. Battery is fine and trackpad works. I might need to post a video to show you what this is doing but I'll try to explain it first.

If I open Safari and start to type in the search bar, all is good unless I start with an "o" or an "L" in the first few letters. As you type, a drop down list appears with autofilled "suggestions". When I get to an "O" or an "L" it starts scrolling rapidly up and down the list, almost as if someone is pressing the down cursor key. I have also discovered that while this is going on, if I mouse up to the menu bar and click on the Apple menu (or File or any of them), the cursor will start cycling down through all the menu items. I think if I press ESC it stops momentarily but that's it.

Here's what I've tried (none have made any difference).

  1. Open up Notepad or TextEdit and type. All keys type as they should.
  2. Reset the SMC - this appears to work. Light on charger goes from orange to green and back to orange again. Good, but no difference.
  3. Reset the PRAM - For some reason, I am unable to do this. When I power on the MacBook it seems to take a ridiculously SHORT amount of time for the Apple logo to appear. On other machines I've done this on there is usually a couple second delay between the startup chime and the Apple Logo - not with this machine. It chimes and then under 1 second later the Apple logo appears. I also tried just holding option to boot from another device - NOPE. I can't even hold D or R or cmd-d or cmd-r to boot to recovery mode. No matter what I try it just immediately starts to boot. I even tried swapping out the SSD with another one with fresh macOS on it and it does EXACTLY the same thing. I also tried sudo nvram -c in terminal but if that does the same thing as cmd-opt-P-R then that did not fix the problem.
  4. Tried a USB keyboard - NOPE, same behavior.
  5. Opened the Mac and disconnected the keyboard, inspected it for corrosion, and reinstalled it. - NOPE same behavior.

What can I try next? I'm out of ideas? It especially concerns me that I can't zap the PRAM on this machine. Is there a way to block this in firmware that I'm not aware of? And if so, how do I unblock it?

Update (08/04/23)

Update: I disconnected the trackpad. It seemed to disable the keyboard as well but I used a USB keyboard and found that the behavior described did NOT occur. It still chimes and displays the Apple logo simultaneously, not allowing enough time for me to activate a modified startup but typing O or L in the Safari url bar no longer activates scrolling. So maybe I need to replace the trackpad assembly? Just the cable? I have no spare parts to test with so ...

Update (08/08/23)

I ordered a new Trackpad assembly but it does not make a difference. Can anyone tell me why the keyboard is disabled when you disconnect the trackpad? Still bothers me that there is no delay between chime and apple logo making it impossible to reset the PRAM or boot from recovery or select a different startup volume. I also swapped out the internal SSD for another with completely different os. Same behavior - starts scrolling down as soon as I press the o or l keys. Do I replace the top case?

Répondu ! Afficher la réponse J'ai le même problème

Cette question est-elle utile ?

Indice 0
Ajouter un commentaire

2 Réponses

Solution retenue

UPDATE: I tried once more to disconnect the internal keyboard and connecting a USB keyboard and the scrolling issue seemed to go away - and I was able to OPTION-Boot and boot to diagnostic mode with the USB keyboard. So I did some more digging - actual digging. I dug the down arrow cursor key out and it looked like there was chunk of lint in it. With the key taken apart the machine DID NOT have the issue. I cleaned the key and put it back together and it started scrolling again. I took it apart again and cleaned it better and now I think it works. If it continues to give problems I think I will need to replace the keyboard (top case assembly). Sorry for not recognizing this earlier and thanks for the responses.

Cette réponse est-elle utile ?

Indice 1

1 commentaire:

No need to apologize! Sounds like you handled it. Sometimes all it takes is getting your thoughts out to get your brain in order. :)

par

Ajouter un commentaire
Réponse la plus utile

So here's the deal with MacBooks with regard to Trackpad and keyboard. Nearly all of them have these two functions tied together, ever if they have separate cables. Essentially they keyboard sends its signals to the board where there are some chips to decode the keyboard strokes, which are eventually transmitted via the trackpad connector. Usually the trackpad contains a daughterboard with components for keyboard processing. But disconnecting the trackpad cable breaks this chain so the necessary data never makes it to where it's going.

This could be the keyboard, itself, or the trackpad cable if you haven't replaced that yet.

Cette réponse est-elle utile ?

Indice 2
Ajouter un commentaire

Ajouter une réponse

Larry Jorgenson sera éternellement reconnaissant.
Nombre de vues :

Dernières 24 heures : 0

7 derniers jours : 2

30 derniers jours : 4

Total : 57