Aller au contenu principal
Aide

Version actuelle par : Dan ,

Titre:

-Display ribbon cab dented display is not being recognized with new one
+DisplayPort cable damaged? Display not being recognized with new one

Texte:

-I think I also damaged mine, although is a 21,5 inch. I opened it to replace the optical drive, and when I was going to close it I didn't inserted the ribbon in a parallel way, resulting in a dented ribbon, I just received the DisplayPort ribbon/cable and to my surprise my display is not being recognized. I'm using an external display, I did a SMC PRAM reset, I took the RAM away and reinserted again but nothing happens.
+I think I damaged mine. I opened it to replace the optical drive, and when I was going to close the system. I didn't inserted the ribbon in a parallel way, resulting in a dented ribbon, I just received the DisplayPort ribbon/cable and to my surprise my display is not being recognized. I'm using an external display now.
+
+I did a SMC PRAM reset, I took the RAM away and reinserted again but nothing happens.
is there anyway to replace it by myself? I'm not in the USA.
Thanks Oldturkey03, pollytintop and Dan: The EMC is 2389. The display doesn't work at all, no backlight no picture, it is not even being detected. Right now I'm working with a Plasma TV.
I had the same problem with the original data ribbon which has the SN: 593-1280 REV A and then part I ordered from Macpartsonline is 593 - 1280A ICT 1611 which appears to be the same except for the way how the code is shown. There is no visible damage on the socket itself.
-The ribbon plugs in both sides naturall, is a perfect fit, so unless the new ribbon is also damaged I blame the display port socket, since the display was fine before I dented the old ribbon, maybe I stretched the socket or broke some pin.
+The ribbon plugs in both sides naturally, its a perfect fit, so unless the new ribbon is also damaged I blame the display port socket, since the display was fine before I dented the old ribbon, maybe I stretched the socket or broke some pin.
-I checked the diagnose LED's and it just lit the first three.
+I checked the diagnose LED's and it just the first three lit.

Appareil:

iMac Intel 21.5" EMC 2389

Statut:

open

Modifié par : Dan ,

Titre:

-DisplayPort ribbon dented display is not being recognized with new one
+Display ribbon cab dented display is not being recognized with new one

Texte:

I think I also damaged mine, although is a 21,5 inch. I opened it to replace the optical drive, and when I was going to close it I didn't inserted the ribbon in a parallel way, resulting in a dented ribbon, I just received the DisplayPort ribbon/cable and to my surprise my display is not being recognized. I'm using an external display, I did a SMC PRAM reset, I took the RAM away and reinserted again but nothing happens.

is there anyway to replace it by myself? I'm not in the USA.

Thanks Oldturkey03, pollytintop and Dan: The EMC is 2389. The display doesn't work at all, no backlight no picture, it is not even being detected. Right now I'm working with a Plasma TV.

I had the same problem with the original data ribbon which has the SN: 593-1280 REV A and then part I ordered from Macpartsonline is 593 - 1280A ICT 1611 which appears to be the same except for the way how the code is shown.  There is no visible damage on the socket itself.

The ribbon plugs in both sides naturall, is a perfect fit, so unless the new ribbon is also damaged I blame the display port socket, since the display was fine before I dented the old ribbon, maybe I stretched the socket or broke some pin.

I checked the diagnose LED's and it just lit the first three.

Appareil:

-iMac 27" Quad Core i7
+iMac Intel 21.5" EMC 2389

Statut:

open

Modifié par : JIgzat ,

Titre:

DisplayPort ribbon dented display is not being recognized with new one

Texte:

I think I also damaged mine, although is a 21,5 inch. I opened it to replace the optical drive, and when I was going to close it I didn't inserted the ribbon in a parallel way, resulting in a dented ribbon, I just received the DisplayPort ribbon/cable and to my surprise my display is not being recognized. I'm using an external display, I did a SMC PRAM reset, I took the RAM away and reinserted again but nothing happens.
is there anyway to replace it by myself? I'm not in the USA.
-Thanks Oldturkey03: The EMC is 2389. The display doesn't work at all, no backlight no picture, it is not even being detected. Right now I'm working with a Plasma TV.
+Thanks Oldturkey03, pollytintop and Dan: The EMC is 2389. The display doesn't work at all, no backlight no picture, it is not even being detected. Right now I'm working with a Plasma TV.
-I had the same problem with the original data ribbon which has the SN: 593-1280 REV A and then part I ordered from Macpartsonline is 593 - 1280A ICT 1611 which appears to be the same except for the way how the code is shown. There is no visible damage on the socket itself.
+I had the same problem with the original data ribbon which has the SN: 593-1280 REV A and then part I ordered from Macpartsonline is 593 - 1280A ICT 1611 which appears to be the same except for the way how the code is shown. There is no visible damage on the socket itself.
The ribbon plugs in both sides naturall, is a perfect fit, so unless the new ribbon is also damaged I blame the display port socket, since the display was fine before I dented the old ribbon, maybe I stretched the socket or broke some pin.
I checked the diagnose LED's and it just lit the first three.

Appareil:

iMac 27" Quad Core i7

Statut:

open

Modifié par : JIgzat ,

Titre:

-DisplayPort ribbon/cable now display is not being recognized
+DisplayPort ribbon dented display is not being recognized with new one

Texte:

I think I also damaged mine, although is a 21,5 inch. I opened it to replace the optical drive, and when I was going to close it I didn't inserted the ribbon in a parallel way, resulting in a dented ribbon, I just received the DisplayPort ribbon/cable and to my surprise my display is not being recognized. I'm using an external display, I did a SMC PRAM reset, I took the RAM away and reinserted again but nothing happens.
is there anyway to replace it by myself? I'm not in the USA.
+
+Thanks Oldturkey03: The EMC is 2389. The display doesn't work at all, no backlight no picture, it is not even being detected. Right now I'm working with a Plasma TV.
+
+I had the same problem with the original data ribbon which has the SN: 593-1280 REV A and then part I ordered from Macpartsonline is 593 - 1280A ICT 1611 which appears to be the same except for the way how the code is shown. There is no visible damage on the socket itself.
+
+The ribbon plugs in both sides naturall, is a perfect fit, so unless the new ribbon is also damaged I blame the display port socket, since the display was fine before I dented the old ribbon, maybe I stretched the socket or broke some pin.
+
+I checked the diagnose LED's and it just lit the first three.

Appareil:

iMac 27" Quad Core i7

Statut:

open

Modifié par : oldturkey03 ,

Titre:

-No Title (You should edit this question)
+DisplayPort ribbon/cable now display is not being recognized

Texte:

I think I also damaged mine, although is a 21,5 inch. I opened it to replace the optical drive, and when I was going to close it I didn't inserted the ribbon in a parallel way, resulting in a dented ribbon, I just received the DisplayPort ribbon/cable and to my surprise my display is not being recognized. I'm using an external display, I did a SMC PRAM reset, I took the RAM away and reinserted again but nothing happens.

is there anyway to replace it by myself? I'm not in the USA.

Appareil:

iMac 27" Quad Core i7

Statut:

open

Contribution d'origine par : JIgzat ,

Titre:

No Title (You should edit this question)

Texte:

I think I also damaged mine, although is a 21,5 inch. I opened it to replace the optical drive, and when I was going to close it I didn't inserted the ribbon in a parallel way, resulting in a dented ribbon, I just received the DisplayPort ribbon/cable and to my surprise my display is not being recognized. I'm using an external display, I did a SMC PRAM reset, I took the RAM away and reinserted again but nothing happens.

is there anyway to replace it by myself? I'm not in the USA.

Appareil:

iMac 27" Quad Core i7

Statut:

open