Aller au contenu principal
Aide

Version actuelle par : Sam Goldheart (détails du vote) ,

Titre:

Why is my power button not working?

Texte:

I recently got an old Toshiba satellite L650 from a family member. It’s battery didn’t have much strength (I mean a full charged battery would drain in 10 mins). So, I used to plug in an use it like a PC. One morning when I plugged in, the indicator LEDs (lights that get lit when plugged in or when it’s charging) lit but the power button wasn’t working. No matter how many times I click or how hard I click. I removed the battery and plugged it in. Still the same.

Anyone else experienced this problem? If yes, can it be fixed without power button replacement?

Please reply ASAP, I can’t buy another for months.

Appareil:

Toshiba satellite L650

Statut:

deletedopen
deletedopen

Modifié par : iRobot ,

Titre:

Why is my power button not working?

Texte:

I recently got an old Toshiba satellite L650 from a family member. It’s battery didn’t have much strength (I mean a full charged battery would drain in 10 mins). So, I used to plug in an use it like a PC. One morning when I plugged in, the indicator LEDs (lights that get lit when plugged in or when it’s charging) lit but the power button wasn’t working. No matter how many times I click or how hard I click. I removed the battery and plugged it in. Still the same.

Anyone else experienced this problem? If yes, can it be fixed without power button replacement?

Please reply ASAP, I can’t buy another for months.

Appareil:

Toshiba satellite L650

Statut:

opendeleted
opendeleted

Message d'origine par : Fazeel ,

Titre:

Why is my power button not working?

Texte:

I recently got an old Toshiba satellite L650 from a family member. It’s battery didn’t have much strength (I mean a full charged battery would drain in 10 mins). So, I used to plug in an use it like a PC. One morning when I plugged in, the indicator LEDs (lights that get lit when plugged in or when it’s charging) lit but the power button wasn’t working. No matter how many times I click or how hard I click. I removed the battery and plugged it in. Still the same.

Anyone else experienced this problem? If yes, can it be fixed without power button replacement?

Please reply ASAP, I can’t buy another for months.

Appareil:

Toshiba satellite L650

Statut:

open