Aller au contenu principal

Réparez vos affaires

Droit à la réparation

Boutique

Aide

Version actuelle par : Brendan ,

Titre:

GBA turns on but has a blank screen and no audio

Texte:

Hey everyone,

I recently acquired a broken GBA that initially didn't turn on at all. After doing all the normal cleaning up corrosion on the battery contacts, unjunking the power switch with IPA etc it now switches on, as indicated by the green LED, but nothing shows on the screen at all. I even hear a bit of noise from the speaker, so I know that works, however, it's just the *bunk* sorta sound you hear from turning the console on - there's no sound from the game or startup sequence. I should add that I hear this through the headphones too.

I've checked the ribbon cable connecting the screen and logic board and nothing seems amiss - I've also thoroughly cleaned both the ribbon cable connector and slot with no luck.

Any ideas?

Appareil:

Game Boy Advance

Statut:

open

Réponse acceptée:

534679

Contribution d'origine par : Brendan ,

Titre:

GBA turns on but has a blank screen and no audio

Texte:

Hey everyone,

I recently acquired a broken GBA that initially didn't turn on at all. After doing all the normal cleaning up corrosion on the battery contacts, unjunking the power switch with IPA etc it now switches on, as indicated by the green LED, but nothing shows on the screen at all. I even hear a bit of noise from the speaker, so I know that works, however, it's just the *bunk* sorta sound you hear from turning the console on - there's no sound from the game or startup sequence. I should add that I hear this through the headphones too.

I've checked the ribbon cable connecting the screen and logic board and nothing seems amiss - I've also thoroughly cleaned both the ribbon cable connector and slot with no luck.

Any ideas?

Appareil:

Game Boy Advance

Statut:

open