Aller au contenu principal
Aide

Version actuelle par : Philippe Léger ,

Titre:

LCD won't come on — LED #4 is low and #5 is off

Texte:

I upgraded RAM and SSD of a 2017 iMac 21.5”, everything went good.

I was at the last step where you have the adhesive strips ready to be pulled off and you actually plug the LCD connectors to see if everything works before removing the outer part of the adhesive and then sealing it.

Boot was good I could see the factory reset screen, and then.. something bad happened.

The LCD panel slipped by an inch or two and the LCD connector:

[image|1792052]

disconnected by the force of the LCD dropping down… the power connector remained connected and visually there is no damage.

The LCD went dark and now the LEDs are like this:

[image|1792054]

the LED #4 is low and #5 is off.

I have another iMac 2017 same model, so I actually took the monitor on the faulty iMac and it works on the un-damaged iMac.

I think I damaged the LCD connector on the motherboard… not sure of what to do now.. any ideas?

The connector doesn’t look damaged.. but I guess something got unsoldered:

[image|1792056]

Appareil:

iMac Intel 21.5" Retina 4K Display (2017)

Statut:

open

Réponse acceptée:

577121

Modifié par : Philippe Léger ,

Titre:

LCD won't come on — LED #4 is low and #5 is off

Texte:

I upgraded RAM and SSD of a 2017 iMac 21.5”, everything went good.
 
I was at the last step where you have the adhesive strips ready to be pulled off and you actually plug the LCD connectors to see if everything works before removing the outer part of the adhesive and then sealing it.
 
Boot was good I could see the factory reset screen, and then.. something bad happened.
 
The LCD panel slipped by an inch or two and the LCD connector:
 
[image|1792052]
 
disconnected by the force of the LCD dropping down… the power connector remained connected and visually there is no damage.
 
The LCD went dark and now the LEDs are like this:
 
[image|1792054]
 
the LED #4 is low and #5 is off.
 
I have another iMac 2017 same model, so I actually took the monitor on the faulty iMac and it works on the un-damaged iMac.
 
I think I damaged the LCD connector on the motherboard… not sure of what to do now.. any ideas?
 
The connector doesn’t look damaged.. but I guess something got unsoldered:
 
[image|1792056]

Appareil:

iMac Intel 21.5" Retina 4K Display (2017)

Statut:

open

Message d'origine par : Philippe Léger ,

Titre:

LCD won't come on — LED #4 is low and #5 is off

Texte:

I upgraded RAM and SSD of a 2017 iMac 21.5”, everything went good.

I was at the last step where you have the adhesive strips ready to be pulled off and you actually plug the LCD connectors to see if everything works before removing the outer part of the adhesive and then sealing it.

Boot was good I could see the factory reset screen, and then.. something bad happened.

The LCD panel slipped by an inch or two and the LCD connector:

[image|1792052]

disconnected by the force of the LCD dropping down… the power connector remained connected and visually there is no damage.

The LCD went dark and now the LEDs are like this:

[image|1792054]

the LED #4 is low and #5 is off.

I have another iMac 2017 same model, so I actually took the monitor on the faulty iMac and it works on the un-damaged iMac.

I think I damaged the LCD connector on the motherboard… not sure of what to do now.. any ideas?

Appareil:

iMac Intel 21.5" Retina 4K Display (2017)

Statut:

open