Aller au contenu principal

Repair and disassembly guides for guitar amplifiers.

71 questions Voir tout

I have power but no sound

My Fender Champion 30 amplifier has power, but I get no sound through the speaker. I looked at the circuit board. welds looked good. My volume control knob is missing and the stud the knob goes to is broke off. I'm thinking this is the problem. I get no sound of static through the speaker. I can't find a related pic of the circuit bourd or were to go to get a replacement.

Répondre à cette question J'ai le même problème

Cette question est-elle utile ?

Indice -1
Ajouter un commentaire

1 Réponse

Réponse la plus utile

anthony, it is entirely possible that the broken pot is your issue. It would be great if you could post a picture of your amp's logic board with your question. The volume potentiometer for the Champion 30 is a 50K 15A which appears to be a "log Pot" you should get those pretty much anywhere, try Mouser.com or Digikey. com, just watch the shipping:-) If you really want to, you can get original replacements from here Of course, you will need to know how to solder to replace it. Hope this helps, good luck.

Cette réponse est-elle utile ?

Indice 1

2 commentaires:

I'll keep you up to date about the fix. thanks

par

I did change the potentiometer.Now it works.I have another issue. When I turn the amp off, I get a loud pop or loud click. I turn the volume off and I still get it. Any ideas?

par

Ajouter un commentaire

Ajouter une réponse

anthony sera éternellement reconnaissant.
Nombre de vues :

Dernières 24 heures : 0

7 derniers jours : 0

30 derniers jours : 0

Total : 2,840