Aller au contenu principal

Réparez vos affaires

Droit à la réparation

Boutique

Processeur Intel Core Duo de 1.83, 2.00 ou 2.16 GHz

Questions au sujet de 356 Voir tout

Keyboard works in Windows unter VMWare but not with OSX

Hallo,

I have a bad problem with my Mac Book:

When I start my MacBook i can´t type Letters. When I start Windows unter VMWare i can type normaly on the keyboard. When I but an external USB-Keyboard on the MacBook I can also Type normaly with it. I´ve tried everything: I´ve started from Install-Disk. No success! I´ve fomatet my Disk an installed a new System and have made all Online-Updates. No success! I´ve but out the accu and started only with power supply. No success!

Does anybody has an idea, how I can fix the problem?

Sorry about my bad english.

Greetings from Germany

Dieter

Répondre à cette question J'ai le même problème

Cette question est-elle utile ?

Indice 0
Ajouter un commentaire

2 solutions

Réponse la plus utile

Hallo, we´ve found the problem. The °ctrl“-Key is hanging. So we have to fix the key or change the keyboard. Thank you Dieter

Cette réponse a-t-elle été utile ?

Indice 1
Ajouter un commentaire

I would suggest checking keyboard settings in Snow Leopard. go to system preferences and then to keyboard. try to look for some errors there. Also, try to change language to different and then back.

let us know if any success

Cette réponse a-t-elle été utile ?

Indice 0

Commentaires:

Hello,

many thanks for your answer. Unfortunately, your advice does not fix my problem. What I would still like to add to my mistake description, is the following phenomenon. Do I click with the mouse on the monitor, I get a contextmenue with the commands „Copy, Past, etc.“ This to itself also no more but away. It disappears only, if I click the "Esc“-key. Besides, have I found out that I can write numbers with the "onboard-Keyboard“, if I put down the "Alt“-button. Unfortunately, letters do not go. With an external USB-Keyboard i can write everything.

I would still like to mention that I have always restart the MacBook as I´ve switched he language. Unfortunately, without success.

Many thanks already for other tips.

Kind regards

Dieter

par

Hello,

the MacBook Pro 15 "is approx. 2 years old:

I have already tried the following things:

MacBook new formatted and a new system installed.-> no success

System updates.-> no success

MacBook of the power supply taken and the accumulator put out.-> no success;-)

Accumulator again built-in and in the power supply connected.-> no success

In the system the language rearranged and new start-> no success

I cannot delete the pram, because it does not accept the keys. Also not from the external keyboard by a new start.

par

Now has struck me a little bit:

If I the key„ P“ press, jump it in a text a line back to top.

Do I press the key„ D“ , it deletes in each case the letter standing on the right beside the cursor.

Do I press the key„ F“, the cursor a letter further jumps to the right.

Do I press the key„ H“ if he deletes in each case the letter standing on the left beside the cursor.

Does one press the key„ K“, the rest is deleted in the line on the right from the cursor.

Do I hold with the text input them„ Alt“ key low, it writes all special characters properly, E.G., with„ Old“ +R it writes ®

with„ Old“ +L it writes @ etc.

par

Dieter, is it possible you could take it to apple store in Germany? iam suspecting faulty keyboard controller. Apple store should be able to diagnose your laptop for free. Just explain the situation.

par

But it still can be just software fault. Because you can use the system and write in under VMWare, it must be something wrong with installation files....

par

Voir 3 commentaires en plus

Ajouter un commentaire

Ajouter une réponse

Dieter sera éternellement reconnaissant.
Afficher les statistiques:

Dernières 24 heures : 0

7 derniers jours : 0

30 derniers jours : 1

Total : 2,724