Aller au contenu principal

I have akai am-m830 no power?

I have just dug out my old akai stack but the amp isnt recieving power checked all the fuses inside and out nothing seem wrong but lights flick on then off what could this be

Répondez à cette question J'ai le même problème

Cette question est-elle utile ?

Score 0
Ajouter un commentaire

Fix Kits pour batterie de MacBook

À partir de $69.99

Buy Now

Fix Kits pour batterie de MacBook

À partir de $69.99

Buy Now

1 réponse

Most amps and stereo systems have protection against liquid ingress, take the top off and leave it to air out in a room at a reasonable temperature. If it has been in storage it could be condensation on the main board., if so airing it out could fix it.

Cette réponse est utile ?

Score 0

Commentaires:

I will try this it was thick with dust so i have cleaned it all out hopefully things will change tomorrow cant wait to play some old skool tapes

par

Excellent, please come back if it works or not, there might be more you can try. Good luck.

par

Still nothing im going to pull the rest of the decks apart for a thorough clean any thing in particular i should look out for ?

par

That's a pity. Just check that there is no crud connecting chip pins on the board. If you could also add a picture or 2 of the board I will have a look at it to see if there is anything I can see.

par

Ajouter un commentaire

Ajoutez une réponse

Stefan miles sera éternellement reconnaissant.
Voir les statistiques:

Dernières 24 heures : 0

7 derniers jours : 0

30 derniers jours : 1

Total : 37