Aller au contenu principal

Rectangular Form Factor / 16 GB capacity / Announced September 12th, 2012

111 questions Voir tout

New battery not charging

Hi all!

Have an Ipod Nano 7th Gen that was immediately dying upon removing it from power so I opened it up and soldered in a new battery. Now it no longer turns off when disconnected from power but it also doesn’t charge to 100%. I left it in for several hours on multiple chargers and it always shows around 1/4 charge or less. Any ideas? Could the replacement battery be bad? Did I not solder in the 3rd lead properly (assuming that one might be for battery status).

Thanks in advance for any suggestions. These are still good MP3 players in 2021 but little to no help or support from Apple.

Répondre à cette question J'ai le même problème

Cette question est-elle utile ?

Indice 0
Ajouter un commentaire

3 Réponses

the third lead talks to the charging circuit. Without it, the charging circuit has no way of knowing what the charge level is of the battery, so I would guess that is why it isn’t charging. If it were to charge with it open or maybe shorted. it would overcharge an LI battery and burn down your house.

Cette réponse est-elle utile ?

Indice 0
Ajouter un commentaire

Thanks for the reply @ruggb. My house hasn't burned down yet so that's all good!

When plugged in it shows the charging icon. I have it running on battery now connected to speakers to see how long it lasts. Maybe it just needs to be calibrated? Solder joints looked good. Not sure…

Cette réponse est-elle utile ?

Indice 0
Ajouter un commentaire

So I’ve been charging it on and off for the past several days and now the battery actual shows 100%! Very weird. Will need to use it more and see if I actually got a good battery or not though. Thanks for the tips.

Cette réponse est-elle utile ?

Indice 0
Ajouter un commentaire

Ajouter une réponse

Allen sera éternellement reconnaissant.
Nombre de vues :

Dernières 24 heures : 0

7 derniers jours : 1

30 derniers jours : 12

Total : 212