Aller au contenu principal

L'Asus Transformer Book T100TA est une tablette hybride Windows 8.1 .

76 questions Voir tout

How can I save BIOS changes without a keyboard

Hello, my Son was given one of these but it sees the previous owner deleted all files including the OS and also has damaged the keyboard,,,

I want to try and load another OS but although I can get into the BIOS to make changes. ( Hold Power Down and Vol Up ) I can't save any changes.. Are there some secret Key presses..

I have tried to connect a USB micro keypad and large keyboard but they are not detected by the Pad if I reboot..

HELP and thanks,,

Répondre à cette question J'ai le même problème

Cette question est-elle utile ?

Indice 1
Ajouter un commentaire

5 Réponses

Réponse la plus utile

What changes do you need to make? If it's a boot order setting, you may not need to.

If the device has no OS, connect or insert your installation media (USB drive, disk, etc..). In theory, when you turn the device on, it scans through the list of boot options in order of priority, until it finds a viable one in the list. If the install media type is higher in the boot priority list than any other "viable" OS, the laptop should automatically boot to it.

Complications may arise if that's not the case.

Cette réponse est-elle utile ?

Indice 2

3 commentaires:

unfortunately the person did not read the question


@johnnb I just reread your question to be sure I didn't miss anything, but I still stand by my answer. What didn't I catch?

I will also reassert my previous points because we do not have enough information to address your issue thoroughly.

* What are you trying to change in BIOS and why? You should not need to make changes in BIOS to boot to installation media if no other OS is installed.

* If DO need to change settings (secure boot, Legacy boot, etc...), we may be able to advise ways around that, but we need to know what you need to change.

* Is there an OS, or remnants of an OS currently installed on any drives connected? If so, disconnect them first and wipe them using another machine if possible so the device does not drive to boot to it.


HI No worries... The Boot manager is disabled and the USB is also disabled, hence the original question.

I have to assume from your reply it that it is NOT possible to adjust and reset the BIOS without a keyboard or you hav never had to look into this

Never mind, I will scrap it



Ajouter un commentaire

@johnnb why would you scrap it? At least you could try a few more things. Try to reflash the BIOS. Turn it on by pressing the Power and Esc buttons at the same time. Get a BIOS Update from places like this Insert the USB drive with the BIOS update on it while you do this. See if that updates your Asus.

Worst case scenario, get a pre programmed BIOS IC and replace your BIOS. Or you can try and find a working BIOS dump and reprogram your BIOS.

At least give it a try, instead of taking the easy way out, and continuing to feed the profit-before-planet machinery. Our landfills are full of devices that are being scrapped just because users are lost with the repairs.

Repair is War on Entropy!

Cette réponse est-elle utile ?

Indice 0

1 commentaire:

Hello, I don't want to scrap it but not found a solution yet,

The main point is .. I do not have the original keyboard for it..................

You say "Turn it on by pressing the Power and Esc buttons at the same time."

I do not have the original keyboard so I do not have a ESC button

I can get into the BIOS with Power and UP volume pressed together.

I DO have a standard USB keyboards and if I use a gender changer to change the standard USB plug to the Micro one so I can plug it into the USB port, BUT the Tablet does not detect it

After some more playing around I do have a screen display after booting which says


Windows failed to start, Insert , insert installation disc and restart.

I DO HAVE an off board DVD drive and a windows 8.1 ISO, BUT after connecting it to the Tablet and restarting, it does not detect the DVD drive.

I have to assume that the USB lead is a Standard type and not a factory reset type.

I do have a factory Reset type which I got a for a Kindle which is a modified micro but not tried that yet.

In the BIOS the USB says Disabled for USB XCHI DEBUG PORT . I can change that to EHCI .

I can change the setting to ENABLED, but can't save that setting.

So that;' my problem.

I don't want to buy the actual Keyboard to try to get it working and only to find that the 32GB SSD inside is faulty....................................

Thanks for your patients



Ajouter un commentaire

@johnnb Does the touchscreen work in the bios for you? This video seems to show it does. Save and exit is on the last page in the bios.

Cette réponse est-elle utile ?

Indice 0

1 commentaire:

Hi, unfortunately the Touchscreen does not work as I have tried it many times...

Looking at other video, it seems that the touch screen relies on the Drivers that get loaded at some point and assumes that all is OK.

In the video you provided, as you saw, the keyboard it detected when in the Windows OS, so have to assume that it cannoot be detected without the OS loaded.

I was thinking earlier about it and was wondering why some software was written so you can open the BIOS with the Power and Vol down keys, but not a save option. It assumes that Windows and some other critical Drivers are loaded which allows the touchscreen

BUT there has to be a way.... Just not got there yet....But will continue to explore :)

Thanks again for your reply



Ajouter un commentaire

Hello, just to let you know I have solved it..

I managed to get hold of an original Keypoard for it...

After docking the keypad, I could get into the BIOS as usual ( Hold Power Down and Volume down on the tablet )

Connected the off board DVD with Win 8.1 to the mini USB on the side of the tablet.

Restarted it and it did no find the DVD and the screen prompt was saying error with windows, insert disk ( or words to that effect )

Then I noticed there was a full size USB socket on the side of the keyboard

I connected the DVD to that socket and restarted

Same problem

Rechecked the BIOS

Noticed that the BOOT list was - Windows Boot manager selected or Disabled

So I disabled the Windows boot manager and saved the setting.

Restarted and it then found the DVD and installed Windows 8.1

I then decided to install Windows 10 and after finding the various drivers all OK.

There is a lot more info I could add if needed


Cette réponse est-elle utile ?

Indice 0
Ajouter un commentaire

Also, for Windows 10 use the Windows 32BIT 8.1 drivers else it wont work with internal bits

SOCPackage_Intel_BayT_T100TA_Win81_32_VER112 ( else audio driver wont work )





Also so forget to change the Windows configuration to TABLET mode with options for Docked or not Docked else in Tablet mode you will not get an On-Screen Keyboard


Cette réponse est-elle utile ?

Indice 0
Ajouter un commentaire

Ajouter une réponse

Johnn_b sera éternellement reconnaissant.
Nombre de vues :

Dernières 24 heures : 0

7 derniers jours : 5

30 derniers jours : 15

Total : 79