Aller au contenu principal

Flagship smartphone from Huawei released April 2019. Featuring a 6.47" FHD+ OLED screen, in-display fingerprint sensor, 40 MP main camera plus 8 MP telephoto camera and a new earpiece speaker technology. Model VOG-L29 and VOG-L09.

47 questions Voir tout

Battery temperature low, phone not charging

Recently i replaced just front display, not whole case. After that, my phone shows me Battery temp too low, charging paused. (Diag. Tool shows average -4°C to 4°C) AccuBattery app it shows cable, like it is charging, but at 0W, top right battery icon doesnt show lightning (charging). Flex charging cable has been replaced. Another thing, it just doesnt accept new battery i bought when phone started doing this, coz i thought it just might be battery. After connecting new battery, boot shows Huawei logo, then phone shuts down. I actually managed to boot just ONCE for the first time i plugged the new battery, immidiately i tried to charge it, but after that as i mentioned above, no charging logo top right, Accu shows charging, but 0W. So i rebooted, but then Huawei logo, then shut down. And so on..

Another point - I actually managed to charge it ONCE from 10% to 60% without it stopping, battery temp was normal (13-18°C, showing at diagnostic tool, --talking about old battery, which is the one im able to boot with and is still in phone, coz new one doesnt work for me - any ideas why?) Only thing i thought might cause the problem where broken pins on old flex cable i already replaced (pins on mobo seems fine with naked eye, dont have microscope sadly)

So another question, where is temperature sensor actually located, so is there a way to check it if it is ok physically?

Also in eRecovery mode top right icon (battery% one) shows charging when charger plugged in.

I tried :

  • Factory reset (settings)
  • Factory reset (Power+VolUp)
  • Clear cache (Power+VolUp)
  • Hotswap battery while charger in (heard it might boot with the new one coz it thinks its old one)
  • Cleaning pins
  • 5 different chargers from 5W to original one

I BEG FOR HELP, IM SO HOPELESS haha

THANKS FOR ANY TIPS.

Répondre à cette question J'ai le même problème

Cette question est-elle utile ?

Indice 1
Ajouter un commentaire

1 Réponse

@jurajstefanek you've got a lot going on here with your phone. What concerns me is the issue with the new battery. There is no reason that the new one does not work, while the old one does. I would just once more get a new battery. Just in case there are issues with your recent purchased one. The temp low can actually originate from the battery sensor. The other issue can be a failed component in the Charge Temp circuitry. You may want to check RT1601. Also, U1601 is the PMIC for the charging etc. (not the low temperature).You could try a quick reflow and see if that makes a difference.

Block Image

Block Image

Let us know what voltage you show on your battery connector when the charger is connected and when it is disconnected.

Cette réponse est-elle utile ?

Indice 0

2 commentaires:

Sadly i dont have option to do it by myself and to my knowledge no phone repair shops nearby do micro soldering. So i was just able to measure voltage. It jumps to 1V-1,5V, then slowly decrease to 0V. Then after a while jumps again 1V-1,5V and so on.

Reflow is meant by removing part, clean and solder it back, right?

par

@jurajstefanek " 1V-1,5V, then slowly decrease to 0V. Then after a while jumps again 1V-1,5V and so on." that voltage is way to low. It is below the threshold for your phone to even come on. You did measure that on the DC scale? where did you measure that? Post pictures of where you measured the voltage.

Reflow can sometimes be done by just applying heat. IT is not a reball. If you have never done anything like that, this may not be the best project to start practising :-

par

Ajouter un commentaire

Ajouter une réponse

Jurko sera éternellement reconnaissant.
Nombre de vues :

Dernières 24 heures : 0

7 derniers jours : 11

30 derniers jours : 43

Total : 392