Aller au contenu principal

None of the back buttons work

Have you found a fix for this? I ran into this exact same problem. Fixed a loose piece in the camera and now the buttons won't work.

Update (10/18/23)

The entire inside element that holds the lens as well as the sensor was loose. So the lens and sensor wiggled around. I took it apart and put in two small screws and that fixed the issue. At work we have 4 G7s, and theyre all slowly giving out.

Répondre à cette question J'ai le même problème

Cette question est-elle utile ?

Indice 0

1 commentaire:

@joelvanbeek same camera Lumix DMC-G7? What part did you fix?

par

Ajouter un commentaire

1 Réponse

@joelvanbeek try the service code on your camera to see if there is an error code. Make sure that after your work on your camera, that both Flex cables are properly re-connected and that the mainboard is free of any corrosion etc. Also make sure that you check the connectors for the flex cables. Remove the cables and then restart them. Check the ends for any tears etc. Here is the SM Panasonic DMC G7 that will help you with the diagnostic as well as the service for your camera. Let us know what you find.

There is of course always a possibility that this is Firmware related, but check the parts etc. first.

Cette réponse est-elle utile ?

Indice 0
Ajouter un commentaire

Ajouter une réponse

Joel Van Beek sera éternellement reconnaissant.
Nombre de vues :

Dernières 24 heures : 0

7 derniers jours : 0

30 derniers jours : 11

Total : 34