Aller au contenu principal

Why did fan stop working after LCD panel repair?

I just performed a replacement of the LCD panel in my Macbook Core 2 Duo (Penryn). The LCD works great and all the other systems are performing normally. However, when the system gets hot, the fan does not kick in. Eventually the system overheats and shuts down. I installed smcFanControl, and it doesn't do anything to affect the fan. In fact, it shows a fan speed of '000.' This makes me think that something happened to the fan in the process of disassembly/reassembly. I have disassembled again to check on the fan. Disconnecting it wasn't part of the repair, so I hadn't purposely disconnected it, and I verified that the cable was still properly seated. I reseated it for good measure. I checked and there was nothing blocking the fan. Reassembled and fan still would not turn on.

When I was doing the original repair, I had clipped the alligator clip of my anti-static strap onto one of the metal bits of the fan. My thought is that perhaps the strap discharged some static into the fan, or the clip damaged it somehow. Visually it looks fine.

Any thoughts?

Une réponse ! View the answer J'ai le même problème

Cette question est-elle utile ?

Score 0
Ajouter un commentaire

Batteries pour ordinateurs portables

Une réparation facile pour un gain en puissance max.

Acheter maintenant

Batteries pour ordinateurs portables

Une réparation facile pour un gain en puissance max.

Acheter maintenant

1 réponse

Solution retenue

First remove the top case and power up the macbook via the two power pads on the logic board and check if the fan is running. If so check the fan intake to see if it's clogged with dust.

If the fan is not running and you have a multimeter, power off the macbook, detach the fan connector from its socket, power on the macbook via the pads, settle your multimeter to DCV/20, black probe on any logic board screw for ground and red probe to test each fan socket pin. You should get 5V on one of the pins. If you don't have this reading then the logic board is faulty otherwise the fan should be replaced. Be careful to not touch two pins at the same time with the red probe.

Cette réponse est utile ?

Score 2

Commentaires:

The fan isn't running at all. I'm going to see if I can borrow a multimeter from someone to test that out. Thanks for the advice!

par

I ran the test with the multimeter. The voltage on the pins, from left to right (oriented with the fan above) was 0, 3, 3.7, 5. Does this sound correct? Since the fan didn't turn on and one of the pins had a voltage of 5, I'm assuming the problem is with the fan.

par

Yes I guess the fan is faulty. The 5V pin gives the power to the fan engine.

par

FYI, I replaced the fan and everything is working great, now! Thanks for the advice!

par

Ajouter un commentaire

Ajoutez une réponse

Peter Wood sera éternellement reconnaissant.
Voir les statistiques:

Dernières 24 heures : 0

7 derniers jours : 0

30 derniers jours : 0

Total : 170