Aller au contenu principal

The Shark Rotator NV502 vacuum was made in 2013, weighs 15.5 pounds, and includes a lift away handle. The vacuum can be used on both carpet and hardwood floors.

17 questions Voir tout

Why won’t my vacuum turn on?

I've pushed the 'ON' button on the vacuum , but it wont turn on. What can i do?

Répondu ! Afficher la réponse J'ai le même problème

Cette question est-elle utile ?

Indice 6
11 commentaires

Yesterday mine just stopped. The light is working, it's not clogged up. Nothing happens at all till I drop the handle and then the brush roller spins but that's it. No suction or anything. Put the handle back in the upright position and everything stops. ????? Help.

par

Exactly what is happening to mine!!

par

Same = see my answer below

par

Mine just started doing the same. How do you fix it?

par

Mine too grrrr

par

Voir 6 commentaires en plus

Ajouter un commentaire

14 Réponses

Solution retenue

First, make sure the vacuum is plugged in. If the vacuum is plugged in and the switch is pushed on, but it's not turning on then try to reset your circuit breaker or reset the motor thermostat. The steps to reset the motor thermostat can be found in the troubleshooting guide.

Cette réponse est-elle utile ?

Indice 4

3 commentaires:

This is not the question asked. The brushbar turns (so the power is on) and there is no suction.

par

mine was doing the same thing, the power to the brush would turn on but the actual motor was not. The switch was not operating fully. I took mine completely apart, cleaned the switch and now it works perfectly. It took about an hour and most of that was locating the screws. Also, you will need 2 different size torque bits in order to do that! Hope this helps.

par

Just put together a brand new Shark navigator. Will not turn on. Totally dead. Great product.

par

Ajouter un commentaire
Réponse la plus utile

The collection canister has a switch that engages when it locks in that can wear and not function, try removing the waste canister/collection canister and insert it carefully to attempt to engage the switch

Cette réponse est-elle utile ?

Indice 9

8 commentaires:

Thank you so much! It was that simple.

par

Perhaps the newer models have this switch, but mine doesn't. I'm thinking mine is either fried, or the cord is worn in the vacuums interior.

par

The canister removal and replacement did it. Thanks!

par

6/23/19- This works! I can’t believe it was this simple, stupid. I went through every hose and removed all the strings on the brushes. Been playing with it for 30 minutes until I found this “ifixit” web site!

par

Thank you! That was simple..

par

Voir 3 commentaires en plus

Ajouter un commentaire

Thermal Protection Switch. (For mine)

Clear any obstruction - I found a clog in both sides of the removable elbow below the wand.

Let it cool off for a 15 -30 minutes with the cord unplugged. Some thermal switches will not reset as long as it’s plugged in.

Reassemble if needed, plug it back in, turn it on, and clean.

Cette réponse est-elle utile ?

Indice 2
Ajouter un commentaire

This just happened to me and the issue is the power switch. If I short the switch leads with a screwdriver (after disassembly), the vacuum runs. Now where can I get a new switch...

Cette réponse est-elle utile ?

Indice 1

5 commentaires:

Gloria it was very simple thanks Joey. What a relief!!!!

par

Same problem for me. It only turns on when brush is engaged and handle down. I've cleaned the brush and filters. Brush turns on but the power doesn't come on until I pull the handle down as if to start vacuuming. But no suction. Can anyone help?

par

Hi Carrie, did you get a solution to your problem? I have the same prob.

par

I have the same problem Carrie

par

Same problem as Carrie.

par

Ajouter un commentaire

It's likely the thermal overload which is that 1/4" back thing with two legs coming out and a short one in the middle.

Solder a link from the middle of it to the black wire and you will bypass it.

Keep the vacuum clear and you should have no problems.

You will have no thermal overload for the motor so the next time it may burn the motor but it beats throwing it out

Cette réponse est-elle utile ?

Indice 1
Ajouter un commentaire

Same thing just happened to me, there is power because when I lower handle for brush roll, it works but no suction and when handle is up then nothing, no noise or suction. Crazy, me red and white on worked for years and I have had this less than a year, going to try to use warranty. This model is the purplish one, professional with attatchments, not the slim one or anything, just a better version of my red and white professional one.

Cette réponse est-elle utile ?

Indice 1

3 commentaires:

Hey I have this exact problem now. Did you get yours figured out Christina?

par

Any answer? Mine is the same. No power til lowered and no suction, but brush works.

par

Lisa, Carrie or Christina? Have any of you found a solution? I'm having the same issue.

par

Ajouter un commentaire

In our case, the vacuum just stopped working right in the middle of use. My wife was using it when it happened. When I came home we both looked at it and concluded the roller and lights worked when they were supposed to, bu the vacuum motor itself was not running. Reading this wiki , the motor thermostat seemed like the right answer, but it had been down for well over an hour and should have cooled down by then.

We then UNPLUGGED the machine (it had been plugged in the entire time). Went to dinner, came back, and it worked just fine. Going to clean the filters so it doesnt have to work so hard.

Cette réponse est-elle utile ?

Indice 1
Ajouter un commentaire

Do the vacuum have to set for awhile until it's cool off

Cette réponse est-elle utile ?

Indice 0

2 commentaires:

So what too do

par

hi, mine did same thing and when I checked the front filter I noticed it was hot. Was yours hot, did you get it fixed?

par

Ajouter un commentaire

Nothing happens at all when I switch ours on. No light no noise no nothing. Any ideas?

Cette réponse est-elle utile ?

Indice 0

3 commentaires:

Same with mine. I was literally just using it and it was working fine, and no nothing.

par

Just bought the cordless shark duo clean today put it on to charge the charging lights came on fine and is now fully charged but when I turn it on it is completely dead the only power it has working are the charge lights????

par

I’m having the same issue, were you able to get your resolved.

par

Ajouter un commentaire

I have the Shark Apex Vacuum. I got it for Christmas. I was just using it to suck up dirt on the floor. Went to turn it back on but the rollers won’t roll. The light on the vacuum comes on and then the light starts to blink. Help!!!!

Cette réponse est-elle utile ?

Indice 0

3 commentaires:

Hope to hear back with an answer soon.

par

Reset the unit by turning it completely off and wait for 2-3 minutes before turning it on again. This will reset the vacuum cleaner’s system and fixes the errors or bugs inside.

par

I have the same problem with shark rocket vacuum. Suction motor works. The roller does not work. There is light on the board. I removed the roller cover and directed the power supply. Now the brush roller and the motor works. I can’t figure out when I attach the suction motor, roller won’t work but there is light on the board.

par

Ajouter un commentaire

We cleaned the filters as it said on the label by the filter and now it works like new.

Cette réponse est-elle utile ?

Indice 0
Ajouter un commentaire

I have the shark duo clean. Lights work but no motor. I was vacuuming and the motor stopped. It's only 6 months old. I unplugged it for 30 minutes, cleaned the filter, and mad sure there's no clogs. Motor still not working. Only the lights.

Cette réponse est-elle utile ?

Indice 0

2 commentaires:

I have the shark duo clean as well. Switched it on and it suddenly went off

par

Pat Voeks mine is doing the same thing. What did you end up doing?

par

Ajouter un commentaire

Hey everyone.. thanks so much for this forum. I didn’t see any answers to mine, so here it goes. My motor turns on, suction works, but no light at all to the indicator light on top of the roller part. I have cleaned all parts, made sure there are no obstructions, made sure all parts are clicked in together and no dirt in the plugs. Still no light on indicator… help please ??????

Cette réponse est-elle utile ?

Indice 0

1 commentaire:

Hi I have AZ950UK WHEN you push it it works when you pull it lights go off and green light can you help me thanks andy

par

Ajouter un commentaire

I have the Shark Duo Clean. Vacuum wouldn’t turn back on when I switched rooms and outlets. Lights went on, roller was spinning and green “brush roll indicator” light was on. I unplugged, rinsed the filter and emptied the waste catcher. Plugged back in and it works perfectly.

Cette réponse est-elle utile ?

Indice 0
Ajouter un commentaire

Ajouter une réponse

Samuel sera éternellement reconnaissant.
Nombre de vues :

Dernières 24 heures : 44

7 derniers jours : 514

30 derniers jours : 2,129

Total : 219,070