Aller au contenu principal

Sorti le 16 septembre 2016, modèle 1778, 1784. Disponible en version 32, 128 ou 256 Go en or rose, or, argent, noir, noir jais et rouge.

Questions au sujet de 1207 Voir tout

iPhone 7 Plus - Front Camera + Proximity Sensor causing malfunctioning

I did a iphone 7 plus screen replacement today & for some reason the phone starts to malfunction everytime I have the Front Camera + Prox Sensor ribbon cable attached. When attached the phone lags, the home button does not work - it shows the accessibilty icon to use as a home button, and the phone acts very weird.

At first I thought it was the replacement screen but I replaced all the part on the original screen that was cracked & I am getting the same issues.

When I disconnect ONLY the Front Camera + Prox sensor Ribbon cable, leaving the two other ribbon cables connected the phone functions perfectly fine. Home button works again, screen is 100% responsive with no lag at all. The phone works perfect.

The issues only occur when I have front camera + prox sensor connected.

I tried the original screen that was cracked & two other replacement screens. All get the same results as I just listed.

As long as the front camera + prox sensor isnt connected the phone functions perfectly, cant find a problem.

Does anyone have a solution to this? Unfortunetley I was unable to try a new proximity sensor + front camera because I did not have any on me.

Has anyone else experienced this problem?

I have searched the web but cannot find a solution.

I disconnected the battery before I removed all 3 ribbon cables, as I do with every repair.

Help would be greatly appreciated ! =D

Répondu ! Afficher la réponse J'ai le même problème

Cette question est-elle utile ?

Indice 9

Commentaires:

Hi.

Try to use new Flex.. new front camera flex

par

I have used a new flex for this same issue. Sometimes it resolves it but not every time. Hope trying the flex works for you!

par

We are running into this issue as well. Camera sensor and mic flex causing hardware check failure in iPhone 7 Plus, so you just see the apple logo reboot itself and repeat. When this flex is pulled, system will boot. When it attached, it does not. Even with new flex. Same issue.

par

We have been running into this issue at work as well with the 6 models. We believe its the aftermarket parts. Yesterday we had phones boot looping, as soon as we unplugged the prox+frontcamera flex ONLY the phone went to working completely fine. I do not know why but this is what we found so far. Will update if we find the exact solution.

par

What did you find out with this? I am having the exact same issue.

par

Voir 6 commentaires en plus

Ajouter un commentaire

9 solutions

Solution retenue

I found the fix!

So I figured out that I was NOT connecting the proximity/front camera ribbon cable fully. It was 75% connected. I kept disconnecting then reconnecting the ribbon cable..Then finally I gave it one final press & I felt the ribbon cable click into place. Fixed!

I was mostly confused on how the phone was reacting with the proximity/front camera cable partially connected. When it was partially connected - the phone would malfunction. It did not recognize the home button which automatically put on assisstive touch. Then the screen would have tremendous lag when switching through panels.

All in all, make sure that proximity/front camera ribbon CLICKS into place! It may look as if the cable is flat, connected but the right side was not fully connected.

I did not even need to use the new replacement proximity/front camera.

Cette réponse a-t-elle été utile ?

Indice 3

Commentaires:

very good.

Always share the solution with us.

I had almost the same issue yesterday.

I couldnt start my iPhone 7 Plus, it kept on Apple Logo and didnt boot all the time.

Then I saw the dock-connector flex cable wasnt fully plugged on logicboard, when I removed it, it started.

Then I put it back again (correctly this time) and it started and worked fine.

par

sometimes it can be the home button that is damaged causing overheat and start up problems... that fixed my problem. i unplugged the home button and it started

par

Ajouter un commentaire

Try new front camera flex

Cette réponse a-t-elle été utile ?

Indice 2

Commentaires:

I will give that a try! thanks.

par

Ajouter un commentaire

Thank you! I was so confused why it was so laggy and unresponsive when camera flux was plugged in. Camera flux cable was actually plugged in upside down so it wasn't functioning properly.

Cette réponse a-t-elle été utile ?

Indice 2

Commentaires:

Thanks for the help! Being that this cable has a twist it can be confusing/forget how it goes. I flipped mine and it works flawlessly now. thanks

par

Ajouter un commentaire

I have same problem with iPhone 7 Plus , when I connect the prolixity/ front camera , the home button and the audio stop working ; take few hours to find out that , I did not the flex cable correctly ( I putted in the other way ) just I changed the the position in the other direction and now working perfect

Cette réponse a-t-elle été utile ?

Indice 1
Ajouter un commentaire

I found the fix! I had the same problem after screen replacement. My home button, front camera, and sound did not work. I tried buying a new ribbon and still no luck. I tried pushing harder on the connection of the camera ribbon and still the same issue. Finally I realized I had plugged it in upside down. Be careful it will click either way you plug it in. The ribbon should be going downwards when it’s plugged in, not toward the top of the phone. Simple mistake but the phone will assemble either way you plug it in. Good luck!

Cette réponse a-t-elle été utile ?

Indice 1

Commentaires:

Yes!!! this was the problem for me! thank you for your help :)

par

Takes a big person to admit something like that. It takes a bigger person to admit you just solved my problem. lol

par

Ajouter un commentaire

I have the same issue. First I was having issues with my microphone. It doesn't work at all. I can't use Siri, I can't talk on the phone, I can't record voice memos. Anyway I opened the phone to see if any ribbon cables we're disconnected or if something stood out but nothing. Upon closing the iphone back up it wouldn't turn on anymore. It's stuck on the Apple boot logo. I tried a restore and the restore was successful but still the iPhone is on boot logo loop. Does anyone else have an alternative solution? Ive been repairing iphones for a very long time and this has never happened before. Luckily it was my own phone I was working on this time and not a customer's phone. Any recommendations would be appreciated. Thanks.

Cette réponse a-t-elle été utile ?

Indice 0

Commentaires:

double check all the connections. Disconnect everything then reconnect everything. You may have a connection not properly connected. Iphone 7 models seem to malfunction the entire phone even if just one sensor is off for some reason.

If you experiecned these issues and its the first time opening this device it seems like you have either a defective phone or the new great iOS 11 has messed up your phone along with all of our phones (my iphone 7 turned to sh*t with the new iOS 11 update) so many problems I dont even want to list.

That is why I bought the pixel 2 and am selling this iphone 7.

Apple messed up big time with this iOS release!

par

No it's not the first time I open this iPhone. I actually opened it in the past because I changed the body from gold to red. It was working fine until the microphone/speaker problem. I delt with the issue for a couple months since I don't really talk much on the phone (I mostly use my phone for texts, emails, games pretty much everything except talking on the phone). I finally got tired of the problem though and that's when I decided to open it just to see if I see anything. I found nothing so I closed it and that's when it all went to sh!t. It never came back on after that. I have checked all connections a million times and still nothing. I guess I have to call it a loss huh?

par

I have heard the front camera andproximty cable getting messed up fromtransfering over . Also some

par

Ajouter un commentaire

Thanks for the good comments on the suggestions. I know a lot more.:k[url=http://www.ufabet99.com/][size=1px]เว็บพนันบอล[/size][/url]

[url=http://www.ufabet99.com/][size=1px]พนันบอล[/size][/url]

[url=http://www.ufabet99.com/][size=1px]พนันบอลออนไลน์[/size][/url]

Cette réponse a-t-elle été utile ?

Indice 0
Ajouter un commentaire

I just replaced a customer’s iPhone 7 Plus screen because it had cracked during a fall. After the repair the phone randomly reboots just like described above. If I disconnect the front camera cable everything is working as intended.

Already tried reconnecting the front camera cable, reinserting it into place, reconnecting all flat cables and shields. I even tried with the original screen (which still works despite the cracks) but same results. Device reboots and fails whenever the front camera cable is inserted.

Guess I’ll try ordering a new flatcable assembly to see if that gives any improvements :/

Cette réponse a-t-elle été utile ?

Indice 0

Commentaires:

Their are 1 of 2 solutions

1. The camera flex cable has been inserted upside down.

2. You have damaged the camera cable.

I discovered when I had the issue with my first iPhone 7 Plus screen repair

par

Ajouter un commentaire

My (one) experience with this issue has shown that the replacement screen is causing the problem, not the front camera flex cable. Am I the only one?

Cette réponse a-t-elle été utile ?

Indice 0
Ajouter un commentaire

Ajouter une réponse

Jonathan Ruel sera éternellement reconnaissant.
Nombre de vues :

Dernières 24 heures : 1

7 derniers jours : 12

30 derniers jours : 51

Total : 36,175