Aller au contenu principal

Processeur dual-core Intel Core i5 à 2,5 GHz (Turbo Boost jusqu'à 3,1 GHz) avec 3 Mo de cache L3 partagé.

Questions au sujet de 259 Voir tout

MagSafe isuues: intermittent but mostly never charges.

My MacBook MagSafe adaptor began working intermittently at first then not at all. I checked the connection and looked for obstructions, none found. Checked the depressable pins , all working as designed. Bought a new charger, worked but only charged to 40 % before lights out! Now I have two chargers that won’t light up or charge.. tried several SMC. Resets to no avail. Purchased new MagSafe board and replaced. Still not working. Checked prices on logic board, around $400 plus. Seems too much to invest in 2012 model. Apple wants over $700 which definitely is not worth it. Does anyone have further suggestions of what I could try? Strangely, every once in awhile I will play with the chargers at the magnetic connection and the light will go on and start charging. As soon as it is unplugged and plugged back in, no light & no charge. I have tried with and without the extension cord that comes with the MagSafe adaptor with the same results. MacBook runs surprisingly well and fast for its age. Hoping to salvage!

Répondre à cette question J'ai le même problème

Cette question est-elle utile ?

Indice 1
1 commentaire

Same issue with mid-2012 15" MBk Pro

par

Ajouter un commentaire

2 Réponses

Réponse la plus utile

I would remove the bottom of it and check very closely for any signs of logic board corrosion first. More than likely your board will require repair to remedy the issue.

I have seen a lot of older MBPs that have wear on the MagSafe connector that can cause intermittent charging issues, but since you've already replaced the board, that's probably not the problem. You may want to try another new one just to double-check, though.

Cette réponse est-elle utile ?

Indice 1
Ajouter un commentaire

My 15" mid-2012 MB Pro has the same issues, but I have not replaced anything other than the charger itself. (Same issues with a brand new charger!) I'm thinking it's the mag-safe connector/circuit that has gone bad from too much stress on the connector while it was plugged in. I have worked mostly with it plugged in since I bought it new. I have owned several Mac laptops and have never seen this problem before on any of them...

Cette réponse est-elle utile ?

Indice 0
Ajouter un commentaire

Ajouter une réponse

granitestatebuilders sera éternellement reconnaissant.
Nombre de vues :

Dernières 24 heures : 0

7 derniers jours : 1

30 derniers jours : 1

Total : 112