Aller au contenu principal

Why my Hoover windtunnel upright vacuum does not turn on?

I plugged the vacuum and turn the power switch on but nothing happens. It doesn't turn on. Please help.

Répondu ! Afficher la réponse J'ai le même problème

Cette question est-elle utile ?

Indice 1
Ajouter un commentaire

1 Réponse

Solution retenue

Hi,

Did it do this from “cold” or had you been using it for a while and just moved the cord to a different wall outlet and tried to use it again?.

If it had been running for a while, allow the motor to cool down for about 15-20 minutes and then try again. There is a thermal protection switch built into the motor which operates and disables the motor if it overheats. This usually occurs if the dust cannister is too full or the filters are clogged and the motor wasn’t getting enough cooling air passing over it.

If it did this from a “cold” start do you know how to use a DMM (digital multimeter) or know someone who does?

If so you can use the DMM’s Ohmmeter function to test that the electrical circuit for the vacuum cleaner is OK from the cord plug pins all the way through the On/Off switch to the motor terminals.

Test from the plug to the switch, to the motor. It could be a faulty plug, cord, switch or motor.

It is safe to test using an Ohmmeter as the cord will NOT be plugged into any power.

Here’s a link to the ifixit Remplacement de l'assemblage du moteur vertical orientable à l'air de Hoover Windtunnel guide which will help in gaining access to the motor etc.

Cette réponse est-elle utile ?

Indice 2
Ajouter un commentaire

Ajouter une réponse

stevepandya sera éternellement reconnaissant.
Nombre de vues :

Dernières 24 heures : 11

7 derniers jours : 86

30 derniers jours : 401

Total : 11,935