"Everything is hooked up but nothing happens!"

Make sure the positive and negative terminals match the + and - inside the battery case.

Replace with a new 9V battery.

The connections may be loose. Use a volt meter to test for current.

"Getting power but my guitar won't do anything!"

Be sure you're using the proper cables and connected to the "input" jack on the amp.

Try using another guitar on amp or use the guitar on another amp to find which device has the problem.

There are many pieces on the board which could cause no sound if they are broken. Check this guide out for more details.

"Got my sweet headphones in but I'm not getting sound from them"

Be sure you have the proper cables or adapters.

There are many pieces on the board which could cause no sound if they are broken. Check this guide out for more details.

"The hissing is disturbing my playing man!"

Check this guide out from replacing your speaker.

There are many pieces on the board which could cause a hissing sound if they are broken. Check this guide out for more details.

"Turning these knobs but my sound won't change."

Check this guide out for testing and replacing your potentiometers.

There are many pieces on the board which could cause your potentiometers to work improperly if they are broken. Check this guide out for more details.

Hi everybody,

I have a problem with my MS-2. It turns on but produces no sound. I took it apart but visually all components and connections seem fine. I haven't tested them, and I'm not sure what I should test. I see that there is a link to a guide, on this page, but the link doesn't work. Did anyone experience the same problem ?

Thank you for your help !

ziuthre - Réponse

Hi Ziuthre, i have the same problem with mine, the led turns on to, but makes no sound at all. some time, a friend, conect it a 12V adapter on it, and.... so, if you have any information about it, please let me know at teratossiete@hotmail.com... same if i know something... thx

Luis Aguirre -

Links are explicitely leading to an error404 page. I mean the page isn't missing, the link is built to show up this 404 page, so I think the guide's never been written :(

"http://www.ifixit.com/404"

agapoffa - Réponse

The tone knob on my Ms-2 is stuck, I can't move it. What do I have to do?

Sander Lijster - Réponse

Gently prise off tone knob with small flat end screw driver. Working your way round till it pops off.

Remove 10mm lock nut with socket. Should only be finger tight so should come off easily. With the amp lying on its back squirt a very small amount of penetrating oil into the shaft / switch. Gently and carefully push the shaft / switch to the side so that oil can work it’s way around. Leave for a minute or two.

Now with a flat ended screw driver (about 7”long for leverage) carefully but firmly try to turn the switch. Should come free at this point.

Mine was stuck for over 10years and it freed up easily. Wipe away any excess oil and reassemble.

Ken -

Ajouter un commentaire

Voir les statistiques:

Dernières 24 heures : 3

7 derniers jours : 25

30 derniers jours : 95

Total : 4,992