Aller au contenu principal

Processeur dual-core Intel Core i5 à 2,5 GHz (Turbo Boost jusqu'à 3,1 GHz) avec 3 Mo de cache L3 partagé.

266 questions Voir tout

Hard Drive/OS not recognized after logic board replacement

So my Late 2012 Macbook Pro 13” Retina works just fine on my existing logic board EXCEPT the charging circuit is whacked so that it never will charge the battery.

If you put a charged battery in, everything is great until you run out of power.

I originally thought it was the MagSafe board or battery but have swapped both with identical results.

So I ordered, received and installed a replacement logic board from IFIXIT. When I plug it into power, after going green then amber on the charge cable, it plays the reboot tone (which is weird, why does it jump right to life without input?) It searches for the hard drive for about a minute and then gives the flashing folder with question mark / no hard drive found. Tried SMC and PRAM resets, reseating hard drive connector and still no go.

I called and informed iFixIt who promptly sent a 2nd replacement. In the meantime, I put my logic board back in and confirmed that everything still booted up as normal.

Received the replacement today, installed, and the same %#*@ thing!

Am I missing something? Are the hard drive connectors a common point of failure and iFixIt just isn’t catching it in their testing before sending out refurbs?

Is it just that I got 2 bad boards and I need to try a 3rd?

Getting tired of pulling this thing apart so many times. Any help is appreciated. Thanks.

Update (05/08/2018)

Block Image

Block Image

Block Image

Block Image

are these what you wanted to see?

Répondu ! Afficher la réponse J'ai le même problème

Cette question est-elle utile ?

Indice 4
Ajouter un commentaire

4 Réponses

Solution retenue

Solved!! So I figured out what was wrong. My system was running High Sierra which means that the internal SSD drive had been converted to the newer APFS file system. Early OS versions are unable to read APFS drives!

Part of the upgrade that enables APFS is a firmware/SMC update to the logic board. The replacement boards that I received had only ever been upgraded through OS-X Mountain Lion. So with the older logic boards there was no way for them to read the internal SSD drive, including the boot partition. Booting with a recovery disk I was able to go into Disk Utilities and determine that my disk was being seen just fine at the hardware level and in fact I could use the Verify function to actually see that all my files were there.

So the solution was to:

  • Attach an external USB drive (formatted to MacOS extended (journaled) with GUID partition scheme. I used a USB 3.0 drive which makes the process considerably faster.
  • Hold Option, Command, R keys to enter Network Recovery
  • Followed prompts to download OS-X Mountain Lion which I installed to the external drive USB drive
  • Once the install of OS-X was complete I checked for updates. It showed an SMC update and some other things so I went ahead and did those updates. Not sure if jumping right to the High Sierra update would have rolled up all of these into one... but didn't want to find out. So I went ahead with them.
  • Then when complete went back to App Store where it was prompting to install High Sierra 10.13.1. Went ahead and did that which includes a fairly long update period with multiple restarts as it upgrades the file system (on the USB drive) and performs the firmware updates to the logic board.
  • Once update was complete it rebooted off the USB drive into High Sierra. Going to Finder it was obvious that everything had worked as I could see all of my internal SSD. So I shut down and disconnected the external USB drive.
  • Powered up and it booted perfectly off my original, intact, internal SSD! Had to feed it a couple of passwords that must have failed some security check or what not... but other than that I was right back to where I was before. DONE!

Thanks to iFixit for their patience while I worked through the troubleshooting to get this solved. So just realize that if you are upgrading the logic board on a computer that is running High Sierra on a SSD... that you need to be swapping in a logic board that has the appropriate SMC and firmware updates completed (i.e. harvested from a High Sierra running machine) or it will not be able to read any of your APFS formatted SSD drives (or if you’ve manually updated your HDD).

You'll have to either manually load the firmware updates (if they are even available stand alone?) or just do as I did, and labor through the OS upgrades to force the updates.

Cette réponse est-elle utile ?

Indice 28

14 commentaires:

Thank you for this. Your steps above got me out of the same jam!


Great to hear Tara!! :-) I'm sure as more people are running High Sierra on these 3-5 year old laptops that still work just fine...more people will be running into this issue. Thanks for the feedback. Glad you got it figured out!


Had to swap a faulty mobo for a user... their drive was showing the flashing folder question mark after boot. Used a USB 3 stick to install 10.12 to from another USB source, updated it to 10.12.6, then fully to 10.13 and saw my original drive. Changed startup disk in system prefs to the APFS SSD and rebooted (removed usb sticks) and all back! Thanks a ton! Took all dang day to update a USB stick through all those versions, but it worked!


This helped me also. Apple store was going to wipe the SSD. I'm so glad I found this, and thank you.

For anyone else who comes here, I had two difficulties in the App Store.

1) To log in, App Store prompts you to "enter the confirmation code after your password". This is the 6-digit code the OS sends to another device when a new device logs into the App Store with your account. OS Lion has no extra field to enter the code since that didn't exist during Lion. You have to append the 6 digits to the end of your password with no spaces - "MyPassword123456"

2) I didn't see the option to upgrade OS-X Lion any longer in the App Store. In the App store, I clicked the "Purchased" tab and was able to download OS-X Mavericks to the USB, the next OS above Lion. This was painful to do via a normal 64GB USB and has taken two days but it is almost done.

After Mavericks finally installed on the USB, I booted from the USB and attempted to access the app store. App store hung. To solve:

1) Though I had already used the utility that comes up with pressing "option" after the boot chime to connect to my wireless, I had to do this again once the Mavericks OS came up.

2) If App store still hangs, you have to open the disk utility and repair disk permissions.

3) If App store still hangs, you have open terminal and

open $TMPDIR../C and delete any folder that references app store

open $TMPDIR../T and delete any folder that references app store

* Reboot and reconnect the wireless once in Mavericks

* Finally at this point app store opens and prompts me to upgrade to High Sierra.

I will update this comment if I run into other issues.

== UPDATE ==

After Mavericks, the High Sierra download claimed to install, but actually installation failed. So I wound up downloading and installing Yosemite and El Capitan to the USB prior to re-attempting to finally install High Sierra.


Discovered the flashing folder/question mark after replacing the logic board in my 2012. Exacerbated until I found your post. I ended up going from Lion to Maverick to High Sierra and now Mohave. Couldn't see where the firmware modification occurred, but it did. Thanks to you Tim I am up and running. Well done.


Voir 9 commentaires en plus

Ajouter un commentaire

I'm suspecting you encrypted your drive so it will only work in your original logic board as its keyed to the S/N of your system. It won't work with the replacement board.

Review this: Use FileVault to encrypt the startup disk on your Mac

You'll need to create a bootable drive so you can enter the recovery key to unlock the drive. If you lost it heres a way to regain it: Obtain FileVault 2 recovery key with administrator account

And if you can't recover it - Ouch! Want to recover a FileVault-encrypted drive without a recovery key? You’re out of luck

While you can undo file vault it will take some time! Your other option is to make a backup (un-encrypted) so you can wipe the drive down and re-install your OS and then recover your backup.

Cette réponse est-elle utile ?

Indice 1

5 commentaires:

I don't think I have FileVault turned on...but I'll swap back to my good logic board (except for the charging problem) and double check. Thanks for the idea. I'll report back.


So I'm typing this from my Macbook with my old logic board installed (as the battery charge indicator creeps down...although the replacement board was good for charging it back to full while it was installed). So FileVault was turned no luck there. Are there other drive parameters that get stored on the logic board that make a logic board swap not as simple as it would seem from the Repair Guides? Any other ideas? Or should I just get back with iFixit and try a 3rd board?


What is the logic board number on yours and the replacement? I'm wondering if you got the wrong board. Also what is your SSD? Take a snapshot of the label on the drive and post it here for us to see.


pics posted below in an "Answer"...didn't know how (or if) they could be posted as a Comment


No, you can't post images in comments only Q's & A's. I pushed yours up as an update.


Ajouter un commentaire

Hello guys!

Good day...!!

I am using MacBook early 2009 mb5.2

Max version supported by this Machin is Mac os X ek captain. I recently did a clean install of is High Sierra using patch tool. It's working great, except for the hardware of camera and trackpad. And some times I feel very stuck on page. So I decided to downgrade OS. I had contacted Mac customer service, for any assistance. As per the instructions I went to OS recovery and tried reinstal. It always shows me High Sierra. To click to continue download and install. Where I wanted to roll back to the actual OS that came along with it at the time of purchase.

In an another call with apple service care, I followed the instructions internet recovery.

I went to boot menu DiskStation utility and selecting the Macintosh HD and erased all data, and then tried to recovery Mac os. But still the same high Sierra page to download and install. (Atleast it's not download, gives me an error).

And again later, when I restarted I see not HDD recognised or can't get to recovery mode, or boot access, and none of these combination keys working, : Cmd+R; shift+ option+ command+ R; shift+ control+ command +P, press and hold D key while startup, or any are not working.

Except the error of blinking question mark folder. I doubt my hdd dint fail or any hardware components issue. Like above it's mentioned, I believe that after upgrading to High Sierra my Mac logic board had need updated it's files to latest, and now won't recognise hdd, or can't take me to boot. Or recovery.

Need help. Please somebody.

Cette réponse est-elle utile ?

Indice 0

1 commentaire:

I know this is late, but try just "option" for access to some safe mode options. Also, Apple has changed its boot access keys over the years, so it may take some googling and several attempts to find one.

I think you may need an external boot drive at this point. Unfortunately you will need a working computer to make one, and you will need to make it on something you can hook up to your 2009 (may need to make a CD or DVD, and these are already obsolete for newer Apple computers). You can download the last OS that worked for you by accessing your Apple account (iTunes and Apple store username and pw) and clicking the "purchased" tab. Even though you don't technically purchase the OS's, they should be in the list for you to see.

Good luck!


Ajouter un commentaire

Funny…a SATA drive running 10.13.4 starts just fine but my SSD running 10.13.6 will not. Flashing ?

Cette réponse est-elle utile ?

Indice 0

1 commentaire:

Best to post a fresh question with all of your details as your issue is not what this one is about.


Ajouter un commentaire

Ajouter une réponse

TimD sera éternellement reconnaissant.
Nombre de vues :

Dernières 24 heures : 0

7 derniers jours : 12

30 derniers jours : 33

Total : 17,625