Aller au contenu principal

Released June 2012 / Core i7 processor with Turbo Boost / Up to 1 GB DDR5 Video RAM

Questions au sujet de 581 Voir tout

Random shutdonws after battery replacement

Hey guys, so i got a battery from iFixit and soon after i replaced it i began to get random shutdowns, the mac was running incredibly slow.

I noticed when it started to get really sluggish if i press the button for the battery indicator (the one on the side) it showed like there is no battery (no lights lit green)

Had to reset the SMC in order for it to work properly again.

So i did an SMC & PRAM Reset, tried to charge it to 100% and drain it until 0% a few times but to no avail.

So i messaged them and they sent me another one (the one i got might be defective)

The second one gets here, i replace it and it got even worse, way worse… every 10-20 min. i get shutdowns.

So luckily i kept my original battery which is at 1300 cycles and swapped it just to make sure my mac runs fine with it.

Three days have passed since and i have no issues.

Im running Mojave (last update)

A Data SSD + WD Black

16GB Ram 1333MHz (2 diff sticks)

Block Image

Block Image

Répondre à cette question J'ai le même problème

Cette question est-elle utile ?

Indice 1

Commentaires:

Please tell us about this "A Data SSD and your WD black) set up. Also did these problems begin after you installed Mojave?

par

Mojave is installed on the SSD (A Data SU800), the hdd i use for storage.

No, i've been using Mojave for the past two months or so.

I've been trying to figure out how to fix this battery issue for the past two weeks.

par

Ajouter un commentaire

2 solutions

Réponse la plus utile

Lets get a bit more info on the battery and the charging logic. Install this gem of an app CoconutBattery take a snapshot of main window with the MagSafe plugged in and a second one with it disconnected. Post both here for us to see Ajout d'images à une question existante

I would also recommend you review this Apple T/N to make sure the MagSafe adapter is the correct one as well as the cable & connections are good Apple Portables: Troubleshooting MagSafe adapters.

Cette réponse a-t-elle été utile ?

Indice 2

Commentaires:

I just shipped both batteries back.

The power adapter is the correct one because i bought it two months ago, mines cable was starting to wear quite badly.

I did use CoconutBattery and i dont think i saw anything suspicious.

After a shutdown i booted up the MBP & opened up CoconutBattery just to check if it shows anything under “battery failure” but it never did. Battery status was always “good” if i recall correctly, cycles was at 0 obviously, manufacture date was like in the past 3-6 months.

And i cant & wont bring anything to Apple, because im not the original owner & don’t have the paperwork with the MBP, Plus there is no Apple in this city and i wont be shipping my MBP to them just to have it returned because i'm not the original owner.

par

Can you please post the snapshots I asked for. Lets see what I can glean out of the info. I might surprise you ;-}

par

I have my original battery installed, you still want a screenshot ?

par

I forgot to mention but the shutdowns only happen when the MBP is on battery (not charging).

However sometimes when it is charging the screen goes black and my music stops, after a couple of seconds it resumes (so does the music and the screen flickers) just for a second or two and it goes back to being a black screen, yet its still running (the fans are spinning) and i have to shut it off holding the power button.

par

Well i received the third battery from iFixit and its still the same, though it happens more rarely with this one... haha :(

par

Ajouter un commentaire

I also have a 15" 2012 Mbp shutting down randomly, and which shows one error in ASD SE150 test, pertaining to the ATV table test for the battery, "programmed charge table not in use". This Mbp shuts down randomly every now and then, without giving any error report or kernel panic notification. I know that a funky battery can render havoc, so I now will run it with another battery, which passes the ATV charge table test. This appears to be common issue with aftermarket batteries.

Cette réponse a-t-elle été utile ?

Indice 0
Ajouter un commentaire

Ajouter une réponse

georgi sera éternellement reconnaissant.
Afficher les statistiques:

Dernières 24 heures : 0

7 derniers jours : 0

30 derniers jours : 1

Total : 101